Delete Card refresh problem of Mailing List for Address Book

RESOLVED DUPLICATE of bug 434014

Status

MailNews Core
Address Book
RESOLVED DUPLICATE of bug 434014
14 years ago
10 years ago

People

(Reporter: Karen Huang, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040603 Netscape/7.2 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040603 Netscape/7.2 (ax)

Delete Card refresh problem of Mailing List for Address Book

Reproducible: Always
Steps to Reproduce:
Used Mozilla 1.7:
1 After create some cards for Mailing List
2 Remove/Delete one card from the Mailing List dialog -> select OK


Actual Results:  
Notice that the removed/deleted card still displays on the
Address Book three-pane window (upper right panel)

Expected Results:  
The deleted card should be removed right away

Additional Info: 
1) Problem also occurs when deleting card of Mailing List via the "Delete" button
2) Problem also occurs when deleting card of Mailing List via the context
"Delete" menu
3) Problem also occurs when deleting card of Mailing List via the Edit "Delete
Card" menu

Once you select the Personal Address Book & select the Mail List from the left
panel again, the deleted card will be removed at this point....
(Reporter)

Comment 1

14 years ago
Please ignore the above User-Agent & Build Identifier part.
I am able to reproduce this problem on Mozilla 1.7...
I think Seth has already filed this, and discovered it was already a DUP.
Ignore me, I was thinking of bug 245103, but that's for add, not delete.

But yup, I see this bug too with build 2004-06-08-09.  Confirming on Windows XP.

(Karen, do you need me to give you 'canconfirm' priveleges?)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Before you confirm you should look for existing bugs. This is a dupe of Bug
181165 IMO. Please dupe it.
No, it's absolute not.

1)  This bug is about bringing up the Properties window of a Mailing List, as I
understand it, hence the 'Mailing List dialog' mentioned by Karen in her Steps
to Reproduce.

2)  Bug 181165, which you think this is a DUP of, specifically mentions:

'if You select a list, mark an entry in the card-pane to the right and delete it,
then this ...'

The card-pane he's referring to is not the same as the Mailing List dialog.

Those really are separate bugs, but thanks for the suggestion.

Comment 6

14 years ago
(In reply to comment #5)
> The card-pane he's referring to is not the same as the Mailing List dialog.
Right, but the core problem is: Nevertheless wherever I delete a card from a
mailing list, the card-pane isn't properly updated.

> Those really are separate bugs, but thanks for the suggestion.
I am not sure. At least it should be added a dependency.

Another related bug is Bug 152133.
Ostgote - not knowing the codepaths (and whether or not each card listens for an
event or command), I can't make that qualification.
Product: Browser → Seamonkey

Comment 8

14 years ago
Points 1), 2), 3) from addtional info in comment 0 are bug 181165. 

But I still see the issue if I open a mailing list (you have the extra "Mailing
List" dialog open, doubleclick on a list name (left side) in the three-pane
view) in Mozilla 1.8a6 build 2004112806 on WinNT4. Delete a member address from
the list does not update the AB three-pane view (right side). You have to switch
to another list/AB and back to see the update (address is removed).

Depends on: 181165

Updated

13 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
QA Contact: addressbook
I don't normally do this, but I'm going to dupe this forward to bug 434014. It is much clearer that on that bug what the problem is about, from reading the first comment and summary. Therefore I think its easier to keep that one than it is this one (I have to read it all several times before I remember which one this is).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 434014
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.