Wheel mouse scrolls too quickly

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: mdoocy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

Using a wheel mouse to scroll through a web page "leaps" roughly 17 lines of
text in one wheel notch. This behavior is not exhibited in Mozilla build 20040608.

Reproducible: Always
Steps to Reproduce:
1. Load any web page
2. Use wheel mouse to scroll down 1 (one) "notch"

Actual Results:  
Page scrolls roughly the equivalent of 17 lines of text.

Expected Results:  
Page should have scrolled roughly 3 (as in Safari) to 4 (as in Mozilla/20040608)
lines of text.

Note that this was only tested with Logitech MX 700 Optical Mouse and latest
drivers. Was not tested with another wheel mouse/driver.

Comment 1

14 years ago
*** Bug 261367 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Using RC1, the scroll wheel scrolls four lines of text.  Other OS X apps scroll
one line at a time when scrolling slowly but speed up to about five lines at a
time when scrolling quickly (try iTunes).  I personally would prefer to have
Firefox behave like other apps in this respect.  

Comment 3

14 years ago
I think that this problem is fixed now.
The page of two lines scrolls by wheel scrolling of 1 notch.

Mac OS X 10.3.6
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041111
Firefox/1.0
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041113
Firefox/0.9.1+

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.5) Gecko/20041108 Firefox/1.0
Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.5) Gecko/20041217

I use Firefox 1.0 for Linux and still have the same problem:

I tried to fix this by doing about:config and changing:
mousewheel.withnokey.action
mousewheel.withnokey.numlines
mousewheel.withnokey.sysnumlines

to the same, optimal for me, values as I have set in mozilla 1.7.5. Nothing
happened. It is weird that current mozilla can correctly control mouse wheel and
firefox not. It looks that firefox completly ignores wheel settings from config
file and uses crazy built-in predefined values or probably random values.

Comment 5

14 years ago
(In reply to comment #4)
> to the same, optimal for me, values as I have set in mozilla 1.7.5. Nothing
> happened. It is weird that current mozilla can correctly control mouse wheel and
> firefox not. It looks that firefox completly ignores wheel settings from config
> file and uses crazy built-in predefined values or probably random values.
> 

How about clean installation and a clean profile?

WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050411
Firefox/1.0+
Assignee: bross2 → nobody
marked as WFM per comment 3.

For other platforms, please file a new bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.