M17rc3 crash [@ nsGenericHTMLElement::RecreateFrames]

RESOLVED DUPLICATE of bug 246556

Status

()

Core
HTML: Parser
--
critical
RESOLVED DUPLICATE of bug 246556
14 years ago
6 years ago

People

(Reporter: jay, Unassigned)

Tracking

({crash, topcrash})

Other Branch
x86
Windows XP
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
Not sure what's going on here, but there are a lot of these crashes showing up
in Mozilla 1.7 rc3 Talkback data.  Here are a couple of sets of crashes:

Count   Offset    Real Signature
[ 15   nsGenericHTMLElement::RecreateFrames dd0d0dce -
nsGenericHTMLElement::RecreateFrames ]
 
     Crash date range: 10-JUN-04 to 13-JUN-04
     Min/Max Seconds since last crash: 32 - 91488
     Min/Max Runtime: 5510 - 184505
 
     Count   Platform List 
     15   [Windows NT 5.0 build 2195]   
 
     Count   Build Id List 
     15   2004060810
 
     No of Unique Users         3
 
 Stack trace(Frame) 

	 nsGenericHTMLElement::RecreateFrames
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/html/content/src/nsGenericHTMLElement.cpp
 line 539] 
	 SinkContext::CloseContainer
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp
 line 1477] 
	 HTMLContentSink::CloseContainer
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp
 line 3123] 
	 CNavDTD::CloseContainer
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 3549] 
	 CNavDTD::CloseContainersTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 3581] 
	 CNavDTD::CloseContainersTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 3767] 
	 CNavDTD::HandleEndToken
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 2102] 
	 CNavDTD::HandleToken
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 1027] 
	 CNavDTD::BuildModel
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 520] 
	 nsParser::BuildModel
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsParser.cpp
 line 1899] 
	 nsParser::ResumeParse
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsParser.cpp
 line 1763] 
	 nsParser::OnDataAvailable
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsParser.cpp
 line 2430] 
	 gkparser.dll + 0x29374 (0x61319374)  
	 nsExpatDriver::AddRef
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsExpatDriver.cpp
 line 307] 
	 0x8556104d   
 
     (85783)	URL: www.freeworldiup.com
 
====================================================================================================
     Count   Offset    Real Signature
[ 2   nsGenericHTMLElement::RecreateFrames fb10ae6c -
nsGenericHTMLElement::RecreateFrames ]
 
     Crash date range: 10-JUN-04 to 10-JUN-04
     Min/Max Seconds since last crash: 8 - 22
     Min/Max Runtime: 5532 - 5540
 
     Count   Platform List 
     2   [Windows NT 5.0 build 2195]   
 
     Count   Build Id List 
     2   2004060810
 
     No of Unique Users         1
 
 Stack trace(Frame) 

	 nsGenericHTMLElement::RecreateFrames
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/html/content/src/nsGenericHTMLElement.cpp
 line 539] 
	 SinkContext::CloseContainer
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp
 line 1477] 
	 HTMLContentSink::CloseContainer
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp
 line 3123] 
	 CNavDTD::CloseContainer
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 3549] 
	 CNavDTD::CloseContainersTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 3581] 
	 CNavDTD::CloseContainersTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 3767] 
	 CNavDTD::HandleEndToken
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 2102] 
	 CNavDTD::HandleToken
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 1027] 
	 CNavDTD::BuildModel
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp
 line 520] 
	 nsParser::BuildModel
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsParser.cpp
 line 1899] 
	 nsParser::ResumeParse
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsParser.cpp
 line 1763] 
	 nsParser::OnDataAvailable
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsParser.cpp
 line 2430] 
	 nsContextMenuInfo::GetAssociatedLink
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/embedding/browser/webBrowser/nsContextMenuInfo.cpp
 line 137]  
 
     (85781)	URL: www.freeworldiup.com
(Reporter)

Comment 1

14 years ago
For more incidents (some with urls and comments), try this query:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=nsGenericHTMLElement%3A%3ARecreateFrames

Comment 2

14 years ago
this is a dup of bug 246556
(Reporter)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 246556 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsGenericHTMLElement::RecreateFrames]
You need to log in before you can comment on or make changes to this bug.