"Add engines..." in search-box dropdown does nothing.

VERIFIED FIXED

Status

()

Firefox
Search
P3
major
VERIFIED FIXED
14 years ago
9 years ago

People

(Reporter: erratico, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({fixed-aviary1.0})

unspecified
x86
Linux
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testrunner, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

The menu item in the dropdown menu, from the search-box (the one that typically
displays a capital "G" from Google) does nothing when it's clicked-on.  The item
simply highlights blue, then the menu vanishes.

Reproducible: Always
Steps to Reproduce:
1. Right-click on the search box on the main toolbar
2. Move cursor-arrow to item "Add engines..."
3. Right-click 

Actual Results:  
Nothing.

Expected Results:  
Directed the browser to mozdev.org's or update.mozilla.org's webpage of extensions.
(Reporter)

Comment 1

14 years ago
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Right-click on the search box on the main toolbar
> 2. Move cursor-arrow to item "Add engines..."
> 3. Right-click 
> 

This should read:

1. Left-click on the search box on the main toolbar
2. Move cursor-arrow to item "Add engines..."
3. Left-click

Comment 2

14 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614
Firefox/0.9

I am taken to http://mycroft.mozdev.org/download.html

Comment 3

14 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614
Firefox/0.9

? Invalid

Comment 4

14 years ago
Does nothing.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Comment 5

14 years ago
Maybe it occurs only in Linux.
I've also tested also with a 20040604 build and it didnt' do anything either.

(I only have Linux).

Comment 6

14 years ago
Linux only - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040608
Firefox/0.8.0+

Request blocking 1.0 - Its meant to get a whole lot better for linux
Flags: blocking1.0?

Comment 7

14 years ago
Same problem in Linux. Other menus and the throbber appear to be affected as well.

Comment 8

14 years ago
(In reply to comment #7)
> Same problem in Linux. Other menus and the throbber appear to be affected as well.

Should mention:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Comment 9

14 years ago
Does nothing for me: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040614 Firefox/0.9. 31 engines installed.

Comment 10

14 years ago
WFM on Windows but clearly an issue here on Linux. Confirming + Marking New.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

14 years ago
Same here, does nothing
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
(Reporter)

Comment 12

14 years ago
This appears to be resolved in firefox-0.9.1-i686-linux-gtk2+xft.
Flags: blocking-aviary1.0RC1+
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0+
Priority: -- → P3

Comment 13

14 years ago
Still a continuing issue in version 0.9.1 on Linux --
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Installed to /opt/firefox on Fedora Core 2

Changing ownership/permissions on /opt/firefox/searchplugins does nothing. I
originally thought this might be the issue, but it's not.

Comment 14

14 years ago
I had this same problem some time ago in FF 0.8 Linux. Wiping my profile did the
trick. But I think there is some flaky code somewhere because more people
experience the problem. 

Comment 15

14 years ago
Same with me, does nothing. Using SuSE 9.1, also clicking mozilla icon does not
send me to homepage.

Comment 16

14 years ago
This isn't working for me on Windows XP with 0.9.1 either...(i'm using my
profile imported from 0.8).  Is this really a Linux only bug?
Component: Extension/Theme Manager → Search

Comment 17

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040713
Firefox/0.9.1+, still not working. I don't think this is Linux-only.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040709 Firefox/0.9.2

WFM. I am redirected to mycroft, as I should be.

Updated

14 years ago
Whiteboard: testrunner

Comment 19

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

The add engine button does nothing, and when I go on
http://mycroft.mozdev.org/download.html manually and want to add a search engine
that also doesn't work.
I believe this has been fixed, probably by bsmedberg. worksforme, at any rate,
tar.gz and installer builds
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
this also w4m --marking vrfy'd fixed, tested with 2004080408-0.9+ bits on fedora
core 2.
Status: RESOLVED → VERIFIED

Comment 22

14 years ago
Now it works. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040804 Firefox/0.9.1+.

Comment 23

14 years ago
setting fixed-aviary1.0 for bugfixes checked into branch, for searching purposes.
sorry for bugspam.
Keywords: fixed-aviary1.0

Comment 24

14 years ago
(In reply to comment #21)
> this also w4m --marking vrfy'd fixed, tested with 2004080408-0.9+ bits on fedora
> core 2.

I'm running Windows XP SP2 (RTM) along with Firefox 0.9.3  
Clicking the "add engines" does nothing, and clicking the link provided below
gives an alert saying the page cannot be found.  This bug is obviously not
resolved as it is still reproducable and there is no fix.

This is just one of the many reasons I am disappointed with .9.  I wanted to try
out Sunbird, but it looks like I'll be going back to .8  Why these releases do
nothing but break compatibility, I'll never know....

Comment 25

14 years ago
dpm: Anything done after 0.9 to fix this would not have been released with
0.9.3.  The next release version that would include the fix is 1.0 Preview
Release, or you can try a nightly build if you want to.

Comment 26

14 years ago
(In reply to comment #25)
> dpm: Anything done after 0.9 to fix this would not have been released with
> 0.9.3.  The next release version that would include the fix is 1.0 Preview
> Release, or you can try a nightly build if you want to.

All right, I'll be looking forward to it.  I don't tend to like nightly builds
as I haven't done coding in a very long time, so I'll stick with a more stable
build.

Comment 27

13 years ago
*** Bug 268811 has been marked as a duplicate of this bug. ***

Comment 28

13 years ago
*** Bug 254958 has been marked as a duplicate of this bug. ***
QA Contact: bugs → search
You need to log in before you can comment on or make changes to this bug.