Toolbars jump up and down if the Bookmarks Toolbar is placed to the right of the Help menu

VERIFIED DUPLICATE of bug 247116

Status

()

Firefox
Toolbars and Customization
--
minor
VERIFIED DUPLICATE of bug 247116
14 years ago
9 years ago

People

(Reporter: Oleg Sidletskiy, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

.

Reproducible: Always
Steps to Reproduce:
1. Using the Customize window remove the Bookmarks Toolbar
2. Close the Customize window
3. Using the Customize window add the Bookmarks Toolbar folder to the right of
the Help menu.
4. Watch Firefox menus jump a few pixels up and down.




note: all done with a clean profile

Comment 1

14 years ago
I had Firefox 0.9 also, with the Bookmarks Toolbar to the right of the Help
menu, but with mine, the whole page would jerk every half second or so, as
though the menu bar kept resizing itself. (The status bar at the bottom was the
only thing that wouldn't jump) I uninstalled 0.9 and installed 0.9.1, but it
didn't fix it. It seems to do it only when using some themes: "Firefox (Default)
2.0", "Qute 2.1.1", and "Phoenity 1.1+".

Comment 2

14 years ago
Build Info: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

I can reproduce the error - however the toolbars only jump around when there are
no bookmarks to display on the toolbar.

Also switching to the Firefox Modern theme after the bug has been reproduced and
the bug conditions are 'in-effect' creates another set of navigation buttons and
boxes on the main toolbar.  I think Orbit Grey also does this but Firefox Modern
 should definately trigger it.

Sometimes the jumping will stop, but if you resize the browser window while
'in-effect' the jumping will start up again.

I have played areound with the flexible space, the search bar and the throbber
but I can't find a configuration of toolbars that stops the bug.  The icon in
the address bar looks pretty prominent in the bug overall though.  But that's
just a guess :-)

I previously had quite a few extensions and toolbars in place when I found this
bug, but I have been testing it out on clean profiles and it is definately
repoducable.

Comment 3

14 years ago
Damn I'm so glad it's not just me here, so appart from not putting these themes
in the new version are there any other ideas about how to get rid of this bug?
I've kept version 0.8 since I like the modern theme a lot. I really wish this
gets sorted out actually because I really love firefox, it's made surfing fun again.

Comment 4

14 years ago
Created attachment 155149 [details]
animated gif of what it looks like

I'm also experiencing this.

The conditions under which this happens for me are:

- At least one bookmark in the Bookmarks Toolbar.
- Bookmarks Toolbar placed adjacent to the MenuBar.
- Window resized smaller so that the Bookmarks Toolbar is not visible.

Comment 5

13 years ago
I encountered the same problem in the following situation: right after
installing Firefox (both 0.10 and 0.9) I moved the 'Bookmarks Toolbar Items' to
the right of the 'Help' menu, separated from that with a 'Flexible Space'. I
removed the 'Bookmarks Toolbar' (now empty), and then I emptied the 'Bookmarks
Toolbar Folder'. The window started vibrating, and continued, even after
reinstalling Firefox (I suppose it recorded the settings somewhere else) until I
added a bookmark to the folder.

Comment 6

13 years ago
bizarro.

following steps in comment #5, the webpage content bounces, as does the location
bar favicon

Closing a tab, makes the jumping stop temporarily. Click another tab and the
bounce resumes. 

To get the bounce to stop permanently, use customize to move the Bookmark
Toolbar Items back to the bookmarks tool bar.

bug 252798 also causes issues when the bookmarks toolbar item is put in a *bad*
place. 

Since the Bookmarks Toolbar itself cannot be removed (only closed), would it be
a bad thing to bind the Bookmarks Toolbar Items to the Bookmarks Toolbar such
that they couldn't be moved in customize?  *ducks the bricks* :-)

Comment 7

13 years ago
This problem occurs when the last bookmark disappears as the window is resized
smaller.  As soon as the '>>' eats the last visible bookmark.  The speed and
height of the bounce seems to be affected by the theme.

Comment 8

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050417
Firefox/1.0+

Seems fine here, I just put the bar to the right of the help menu and killed the
bookmarks toolbar as specified.  I don't see what's in the gif happening at all
(thank goodness), so I'm going to say this is FIXED 1.1

Comment 9

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050417
Firefox/1.0+

WFM on trunk, marking this WFM per my testing at comment #8.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 10

13 years ago
Still happening on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050417 Firefox/1.0+

Comment 11

13 years ago
(In reply to comment #10)
> Still happening on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
> Gecko/20050417 Firefox/1.0+

I am still unable to reproduce on 20050417... I will start with a completely new
profile and see if it works, instead of just emptying my bookmarks toolbar as
you suggested in IRC.

Comment 12

13 years ago
> (In reply to comment #10)
>
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050417
Firefox/1.0+

Using perfectly clean profile, following reporters steps and the additional
steps given in IRC, I am unable to reproduce this.  Still WFM.  Perhaps there is
some additional detail about your setup that allows you to reproduce this?  

Comment 13

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050417
Firefox/1.0+

I emptied my bookmarks toolbar folder, and actually set things back to normal,
then re-followed identifiers steps.  I am not using a clean profile.  Still WFM.

Comment 14

13 years ago
From a clean profile here is what you need to do.
1. bring up the customize window 
   a. right click on the reload icon
   b. or view -> toolbars -> customize
2. drag the 'bookmarks toolbar items' next to help menu
3. delete both bookmarks off the bookmarks toolbar
4. watch the page bounce as well as the URL icon and scroll bars

Comment 15

13 years ago
(In reply to comment #14)
> From a clean profile here is what you need to do.
> 1. bring up the customize window 
>    a. right click on the reload icon
>    b. or view -> toolbars -> customize
> 2. drag the 'bookmarks toolbar items' next to help menu
> 3. delete both bookmarks off the bookmarks toolbar
> 4. watch the page bounce as well as the URL icon and scroll bars

Following new steps to reproduce in a clean profile.... no dice, sorry... I
suppose if anybody can reproduce this though, it should be reopened.  I don't
know why I can't reproduce if you can on the same build and environment I am using.

Comment 16

13 years ago
(In reply to comment #14)
> From a clean profile here is what you need to do.
> 1. bring up the customize window 
>    a. right click on the reload icon
>    b. or view -> toolbars -> customize
> 2. drag the 'bookmarks toolbar items' next to help menu
> 3. delete both bookmarks off the bookmarks toolbar
> 4. watch the page bounce as well as the URL icon and scroll bars

Following these steps, I was unable to reproduce the bug, even in the clean
profile which I just created.

Comment 17

13 years ago
Recommend trying a different theme in order to reproduce the problem.  I am not
on trunk, so this shouldn't be considered definitive, but I use Whitehart and
don't get the problem, but a switch to Plastikfox Crystal SVG makes it reappear.

Comment 18

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b2) Gecko/20050418
Firefox/1.0+

Still see this with the default theme.  Decrease width of browser window to less
than the width of the menu bar (File through Help) to definately see this.

Comment 19

13 years ago
I am reopening, more than 1 person can still reproduce this, I am going to try
to reproduce using the advice in comment #18 when I get back from a tech support
housecall.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050419
Firefox/1.0+
I concur with comment 18 - this still happens when I resize the browser window
to be very small. I get a high-frequency 1px movement up and down. Bookmarks are
on the same level as the File/Edit/View/etc menus

Comment 21

13 years ago
(In reply to comment #20)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050419
> Firefox/1.0+
> I concur with comment 18 - this still happens when I resize the browser window
> to be very small. I get a high-frequency 1px movement up and down. Bookmarks are
> on the same level as the File/Edit/View/etc menus

I got the bug on 1.02 then installed 1.03 and 1.04 to no avail. It follows me to
whatever version I go! You are not safe! Yes i am being a bit mello-d but can
anyone tell me when it will be fixed? Cause i reaaaally can't work with bouncy
content windows!
This is the same as bug 247116. These bouncy UI bugs are caused by the bookmarks
toolbar chevron positioning code.

*** This bug has been marked as a duplicate of 247116 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
QA Contact: bugzilla → toolbars

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.