Last Comment Bug 247116 - Web pages bounce/shake/jump when "Bookmarks Toolbar Items" is empty and placed to right of menu bar
: Web pages bounce/shake/jump when "Bookmarks Toolbar Items" is empty and place...
Status: RESOLVED FIXED
For workarounds, see http://kb.mozill...
: verified1.8.0.12, verified1.8.1.4
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: unspecified
: All All
: -- normal with 13 votes (vote)
: ---
Assigned To: Dave Townsend [:mossop]
:
Mentors:
: 247032 254990 255342 256792 257710 259506 259637 260179 269173 269605 280449 290979 291597 296168 296993 297135 298245 316190 319016 320905 325573 325888 328349 328837 330821 332455 332543 333885 334108 335357 338782 343381 343798 345004 345209 346416 349386 354125 354856 356679 356752 358342 358749 361194 361202 361397 362618 363913 364395 366885 367968 368493 369280 370624 370969 371252 374273 375377 376050 376080 376132 376140 376778 376838 377508 377974 378311 380166 380544 382232 386292 451490 488002 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 09:32 PDT by Jason Emery
Modified: 2015-04-07 13:54 PDT (History)
115 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
short demonstration clip Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (228.98 KB, application/x-zip)
2004-11-30 10:51 PST, (Anonymous)
no flags Details
Workaround (884 bytes, patch)
2005-04-09 21:51 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Review
patch rev 1 (1.16 KB, patch)
2007-03-16 17:12 PDT, Dave Townsend [:mossop]
no flags Details | Diff | Review
patch rev 2 (2.20 KB, patch)
2007-03-16 17:40 PDT, Dave Townsend [:mossop]
gavin.sharp: review+
Details | Diff | Review
Branch version of patch (2.22 KB, patch)
2007-03-24 15:22 PDT, Dave Townsend [:mossop]
dtownsend: review+
dveditz: approval1.8.1.4+
dveditz: approval1.8.0.12+
Details | Diff | Review
places version of patch (1.31 KB, patch)
2007-06-26 07:55 PDT, Dave Townsend [:mossop]
asaf: review+
Details | Diff | Review

Description Jason Emery 2004-06-16 09:32:07 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

After modifying the toolbar and deleting all links, the webpage (html) would
start to move up and down rapidly.

Reproducible: Always
Steps to Reproduce:
1. I customized the toolbar by relocating the "Bookmarks Toolbar Items" up
beside the menus (immediately to the right of 'help').
2. Then I deleted all items in the bookarms toolbar (the three default links
after a fresh install).
3. I then went to a new website and the entire page (not the browser interface,
just the html) began to move 10 or so pixels up and down in half-second intervals.
4. Sometimes going to a new page would resolve the 'bouncing', but by minimizing
and maximizing the browser, the problem reoccured.

Actual Results:  
The website would start moving up and down several pixels in half-second intervals.

Expected Results:  
Displayed the webpage without the content moving.

This happened on a fresh install of Firefox, not 10 minutes after completing the
installation.
Comment 1 Phillip Stewart :P 2004-09-04 14:16:18 PDT
dupe of bug 254990 (although I realized this one was filed first)
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-09-04 23:38:38 PDT
*** Bug 254990 has been marked as a duplicate of this bug. ***
Comment 3 Mathieu Pellerin 2004-09-09 03:41:26 PDT
same here... an easy fix would be to keep the size of the "bookmarks toolbar
items" constant ... right now it's like 2px or 3px smaller when nothing is in
there and that's probably why we see the jump (it jumps from empty-state size to
have-some-items-state size constantly)
Comment 4 Ryan Polk (Quark) 2004-09-15 12:49:47 PDT
*** Bug 259637 has been marked as a duplicate of this bug. ***
Comment 5 Ryan Polk (Quark) 2004-09-15 12:50:06 PDT
*** Bug 256792 has been marked as a duplicate of this bug. ***
Comment 6 Ryan Polk (Quark) 2004-09-16 14:53:24 PDT
*** Bug 259506 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Polk (Quark) 2004-09-20 10:39:39 PDT
*** Bug 260179 has been marked as a duplicate of this bug. ***
Comment 8 Vladimir Vukicevic [:vlad] [:vladv] 2004-09-25 12:00:15 PDT
Asa, dbaron, and I spent a little while looking at this, and couldn't figure
anything out.  This is probably a layout bug; someone who knows how our
layout/reflow works and knows how to debug it should probably look at it.
Comment 9 Ben Goodger (use ben at mozilla dot org for email) 2004-09-25 23:36:04 PDT
aiee. Not a "blocker"
Comment 10 Mathieu Pellerin 2004-09-26 21:28:36 PDT
an easy solution for that: make the height of the bookmark toolbar items region
constant; right now when there is no icon, the height is unspecified, creating
the jumping behaviours ... if you place a defined height item (a button for
exemple) in the menu bar (where you have the menu and the bookmark toolbar
items), it'll stop jumping around.

the problem is not present in linux because the menu bar height == the height of
any other toolbar
Comment 11 Peluso 2004-10-26 08:53:42 PDT
*** Bug 257710 has been marked as a duplicate of this bug. ***
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-11-14 01:55:11 PST
*** Bug 269605 has been marked as a duplicate of this bug. ***
Comment 13 (Anonymous) 2004-11-30 10:51:31 PST
Created attachment 167448 [details]
short demonstration clip

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

the webpage is only shaking when firefox is not maximized
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-01-30 12:12:26 PST
*** Bug 280449 has been marked as a duplicate of this bug. ***
Comment 15 Dave Townsend [:mossop] 2005-04-08 04:08:08 PDT
I think the problem occurs even when no customisation of the toolbars has been
done. Yesterday I did a clean install of firefox and imported from IE, and was
given a bouncing start page. If that's what everyone sees when they import from
IE then this should be blocking 1.1
Comment 16 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-04-09 21:51:58 PDT
Created attachment 180246 [details] [diff] [review]
Workaround

The reason this happens, as mentioned in comment 10, is that the menubar is
21px high, by default, while the bookmark toolbar is 23px high when it contains
items, and has no height (effectively 21px) when it doesn't. The resize watcher
toggles the .collapsed property of the chevron at each resize, which in turns
causes a resize event to fire, and we're stuck in a loop. Defining a minimum
height on the toolbar ensures that toggling the chevron's visibility doesn't
trigger a resize, at least not on XP using the default Luna theme (I don't
think it ever was a problem using the Classic theme). This is kind of an ugly
"fix", but I can't think of anything better, at least not at the moment.

Note that the rule can be added to userChrome.css to correct the problem in
current installs.
Comment 17 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-04-19 16:44:13 PDT
*** Bug 290979 has been marked as a duplicate of this bug. ***
Comment 18 Matthias Versen [:Matti] 2005-04-23 09:58:46 PDT
*** Bug 291597 has been marked as a duplicate of this bug. ***
Comment 19 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-05-30 15:22:11 PDT
*** Bug 247032 has been marked as a duplicate of this bug. ***
Comment 20 Robincoers 2005-06-02 02:56:24 PDT
*** Bug 296168 has been marked as a duplicate of this bug. ***
Comment 21 Tristor 2005-06-03 10:56:48 PDT
(In reply to comment #16)
> Created an attachment (id=180246) [edit]
> Workaround
> 
> The reason this happens, as mentioned in comment 10, is that the menubar is
> 21px high, by default, while the bookmark toolbar is 23px high when it contains
> items, and has no height (effectively 21px) when it doesn't. The resize watcher
> toggles the .collapsed property of the chevron at each resize, which in turns
> causes a resize event to fire, and we're stuck in a loop. Defining a minimum
> height on the toolbar ensures that toggling the chevron's visibility doesn't
> trigger a resize, at least not on XP using the default Luna theme (I don't
> think it ever was a problem using the Classic theme). This is kind of an ugly
> "fix", but I can't think of anything better, at least not at the moment.
> 
> Note that the rule can be added to userChrome.css to correct the problem in
> current installs.


Then that was why I was unable to reproduce this on bug 247032.  I was using the
Classic theme (not Luna) when testing.  You are correct in that it does /not/
reproduce using the classic theme.  I, incidentally, had not even thought of
that as a variable in reproduction when testing previously.

Comment 22 Matthias Versen [:Matti] 2005-06-07 14:13:42 PDT
*** Bug 296993 has been marked as a duplicate of this bug. ***
Comment 23 Matthias Versen [:Matti] 2005-06-08 16:28:11 PDT
*** Bug 297135 has been marked as a duplicate of this bug. ***
Comment 24 Nick Messenger 2005-06-20 08:35:07 PDT
*** Bug 298245 has been marked as a duplicate of this bug. ***
Comment 25 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2005-06-24 01:42:54 PDT
*** Bug 269173 has been marked as a duplicate of this bug. ***
Comment 26 Daniel 2005-09-19 00:59:18 PDT
I can confirm this still occurs in the Firefox 1.5 Beta ("Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4").
I left the bookmarks toolbar in the original place, and it still occurs.
Strangely enough it also causes the unoffical googlebar's search listbox to also
shake the same way (I know Mozilla isn't reponsible for third-party extensions,
but thought I'd mention it for the googlebar users, since it's related). If the
"Bookmarks" item is removed from the toolbar (via customization) then it no
longer shakes. I can also confirm that it doesn't occur on the XP classic theme.
A plausible fix could be to set the "Bookmarks" item to a size, like the rest of
the buttons? I haven't looked at the source code, so I don't know what happens
"under the hood".

Daniel
Comment 27 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-10-12 08:39:25 PDT
Bug 178884 is essentially the same bug. This has been changed trunk&branch by
bug 243078, it shouldn't be an issue anymore.
Comment 28 (Anonymous) 2005-12-08 04:57:03 PST
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

after some testing i can't reproduce this bug in FF 1.5 :)
could someone mark this bug as fixed?
Comment 29 phisho 2005-12-13 21:07:15 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I can confirm this still occurs in the Firefox 1.5, on Windows XP.

Reproducible: Always
Steps to Reproduce:
1. Right-click on the toolbar, click "Customize..."
2. Drag "Bookmarks Toolbar Items" to the space next to menu (right hand side of "Help"), then click "Done" to close the "Customize Toolbar" window.
3. In the menu, click "Bookmarks" -> "Manage Bookmarks..." to open Bookmarks manager
4. Delete all bookmarks in the "Bookmarks Toolbar Folder". Once you delete all bookmarks, you can see the webpage and the icon in the location bar shake immediately.

Actual Results:
The webpage would start moving up and down 1 pixel in half-second
intervals.

Expected Results:
the webpage should be displayed without moving.

This happened on a fresh install of Firefox 1.5.
Comment 30 Yuchao719 2005-12-17 22:35:06 PST
This problem didn't occur when I used Windows 98SE uSP(unOfficialServicePack) 2.1a with FFox 1.5  20051216 installed over a previous version.  I did find this bug a few months ago, but I used Firefox 1.4.1 then and didn't have the uSP installed. (In general, the win98se uSP contains all the M$ updates for 98, a few tweak tools and a Win2000 desktp scheme.)

Can someone please confirm this bug in Win 98Second/Standard Edition and/or Win 2000?
Comment 31 Matthias Versen [:Matti] 2005-12-19 20:25:08 PST
*** Bug 320905 has been marked as a duplicate of this bug. ***
Comment 32 Rev. Tommy Hickok 2005-12-21 17:47:35 PST
i have the problem no mofications can't add enhancements and bouncing no matter what i do except for viewing the page in "full page mode"
Comment 33 Ria Klaassen (not reading all bugmail) 2006-02-04 10:27:48 PST
*** Bug 325888 has been marked as a duplicate of this bug. ***
Comment 34 Ria Klaassen (not reading all bugmail) 2006-02-23 12:34:56 PST
*** Bug 328349 has been marked as a duplicate of this bug. ***
Comment 35 Ria Klaassen (not reading all bugmail) 2006-03-17 08:10:02 PST
*** Bug 330821 has been marked as a duplicate of this bug. ***
Comment 36 Ria Klaassen (not reading all bugmail) 2006-04-01 13:35:51 PST
*** Bug 332455 has been marked as a duplicate of this bug. ***
Comment 37 Ria Klaassen (not reading all bugmail) 2006-04-03 00:30:24 PDT
*** Bug 332543 has been marked as a duplicate of this bug. ***
Comment 38 Kevin Brosnan 2006-07-01 23:21:20 PDT
*** Bug 343381 has been marked as a duplicate of this bug. ***
Comment 39 Phil Ringnalda (:philor) 2006-07-06 15:57:00 PDT
*** Bug 343798 has been marked as a duplicate of this bug. ***
Comment 40 Adam Guthrie 2006-07-17 21:43:49 PDT
*** Bug 345004 has been marked as a duplicate of this bug. ***
Comment 41 Anders Conbere 2006-07-19 10:56:07 PDT
*** Bug 345209 has been marked as a duplicate of this bug. ***
Comment 42 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2006-07-29 10:37:46 PDT
*** Bug 346416 has been marked as a duplicate of this bug. ***
Comment 43 Adam Guthrie 2006-09-04 15:38:32 PDT
*** Bug 349386 has been marked as a duplicate of this bug. ***
Comment 44 Becky 2006-09-25 05:58:07 PDT
*** Bug 354125 has been marked as a duplicate of this bug. ***
Comment 45 Ryuichi KUBUKI 2006-09-25 19:44:29 PDT
*** Bug 325573 has been marked as a duplicate of this bug. ***
Comment 46 Adam Guthrie 2006-09-29 12:16:43 PDT
*** Bug 354856 has been marked as a duplicate of this bug. ***
Comment 47 Phil Ringnalda (:philor) 2006-10-14 12:06:08 PDT
*** Bug 356679 has been marked as a duplicate of this bug. ***
Comment 48 Phil Ringnalda (:philor) 2006-10-16 12:51:08 PDT
*** Bug 356752 has been marked as a duplicate of this bug. ***
Comment 49 Bob T 2006-10-21 08:53:38 PDT
After upgrading to Vista RC2, browser window wobbles whenever I open Firefox. Does not occur with any other browsers.
Comment 50 Ria Klaassen (not reading all bugmail) 2006-10-27 03:51:24 PDT
*** Bug 358335 has been marked as a duplicate of this bug. ***
Comment 51 Phil Ringnalda (:philor) 2006-10-27 10:21:53 PDT
*** Bug 358342 has been marked as a duplicate of this bug. ***
Comment 52 Peter Weilbacher 2006-10-29 09:38:49 PST
As basically all the "jump" bugs get duped to this one, I can as well add a comment here...

We see something similar on OS/2, probably triggered in some way by the theme improvements of bug 314843 and bug 336997. Whenever the bookmarks overflow on the bookmarks toolbar and the chevron is shown, various parts of the displayed webpage or the UI can start to jump around. That happens even if the bookmarks toolbar is not placed onto the menubar.

If this makes somebody think of another bug than this one, please tell me.
Comment 53 Peter Weilbacher 2006-10-29 09:45:20 PST
*** Bug 338782 has been marked as a duplicate of this bug. ***
Comment 54 u88484 2006-11-08 06:42:54 PST
Comment on attachment 180246 [details] [diff] [review]
Workaround

No one requested review on this :( Hope it hasn't bitrotted.
Comment 55 Craig Wildfeuer 2006-11-08 12:45:26 PST
I noticed it does it after even opening the Bookmarks menu
Comment 56 Worcester12345 2006-11-08 17:08:24 PST
(In reply to comment #54)
> (From update of attachment 180246 [details] [diff] [review] [edit])
> No one requested review on this :( Hope it hasn't bitrotted.
> 

Seeing this all too often. Isn't there some automated way to find patches which have not been approved yet? Maybe bugzilla needs a better way to flag this/these.
Comment 57 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-11-08 17:13:41 PST
I didn't ask for review on it because I didn't want anyone to review it.
Comment 58 Mycroft Project (CC) 2006-11-19 08:48:05 PST
*** Bug 361202 has been marked as a duplicate of this bug. ***
Comment 59 Adam Guthrie 2006-11-19 13:53:34 PST
*** Bug 361194 has been marked as a duplicate of this bug. ***
Comment 60 Steve England [:stevee] 2006-11-21 09:25:45 PST
*** Bug 361397 has been marked as a duplicate of this bug. ***
Comment 61 Kris Silver 2006-11-23 07:11:08 PST
I'm shocked this serious bug has gone 2 years essentially unfixed.  I've seen this happen to my and many others Firefox, and it often also seems to mess around with the bookmarks themselves, requiring a backup to be re-instated.  Getting around it is not something the majority of users should have to, or would do, thus this is ridding of users and frustrating many others persevereing.

This needs to be looked at broadly in terms of why are users customising the user face in this way?  To move the bookmarks toolbar to somewhere else where space is available, to better use interface space.  Not only is this only possible in an un-usual way of not moving the toolbar itself but turning it off, but it create issues such as this, with something as basic as the customise interface function.

Solution 1: When approx 10% of internet users use bookmarks, and increasing amounts search and other, an entire bookmarks toolbar un-necessary clutter to an approximate 90% majority, and even some of the 10% whom even use bookmarks in this modern day of the web.   Firefox is for the majority yet the only browser forcing an entire un-necessary toolbar on a majority whom dont use it, so turn it off, keep Firefox simple and for the majority, not with the most toolbars and clutter than other browsers with a more simple less cluttered UI.

Solution 2. As per comment 10, the width of the toolbar is variable, if it wasn't, problem fixed, or at least close to. 

This needs increased efforts to actually deal with this bug in one of the above ways, or others some noted in comments above.  2 years is too long for such a bug that I've witnessed effecting many.  
Comment 62 Jeff Maher 2006-11-24 12:56:34 PST
I had been using Firefox 1.5 for a little less than a month in Mac OS 10.4 and XP. However, when I switched my XP installation to the Vista RC1 (Build 5600), FF 1.5 began jumping, as described by many others. The problem usually occurs when I hit CTRL+F to perform a find, but also is already jumping most of the time when the browser is initially opened.
Comment 63 Phil Ringnalda (:philor) 2006-12-14 23:05:21 PST
*** Bug 363913 has been marked as a duplicate of this bug. ***
Comment 64 Tazni 2006-12-21 16:27:23 PST
I removed the bookmarks toolbar and it stopped.
Comment 65 peter h. olsen. 2006-12-22 05:53:45 PST
my FF V.2 is jumping from i start the browser until i close it... bookmark/no bookmark don´t matter and i have reinstalled it more that 3 times... 
Comment 66 Carsten Book [:Tomcat] 2007-01-13 09:37:57 PST
*** Bug 366885 has been marked as a duplicate of this bug. ***
Comment 67 Matthias Versen [:Matti] 2007-01-23 15:02:19 PST
*** Bug 367968 has been marked as a duplicate of this bug. ***
Comment 68 Dave Townsend [:mossop] 2007-01-28 10:14:15 PST
*** Bug 368493 has been marked as a duplicate of this bug. ***
Comment 69 Carsten Book [:Tomcat] 2007-02-04 10:59:06 PST
*** Bug 369280 has been marked as a duplicate of this bug. ***
Comment 70 Marcia Knous [:marcia - use ni] 2007-02-12 12:56:09 PST
nominating for the next release. Vista users are hitting this quite a bit, and would be a win since the behavior will drive people away from using the browser.
Comment 71 Ria Klaassen (not reading all bugmail) 2007-02-16 05:33:48 PST
*** Bug 370624 has been marked as a duplicate of this bug. ***
Comment 72 sion 2007-02-19 12:49:23 PST
Marcia is right, im going to stop using Firefox for a while.

Bookmarks dont seem to affect my jumping, just happens randomly for me, when page is maximised or not, full size or not, loads of tabs 1 tab, bookmarks, no bookmarks.

I've had this problem before when installing certain themes on windows xp using windowsblinds, such as the emerance or w/e theme, made it jump.

im on vista atm and it jumps randomly, right now it isnt. and now i just closed 1 tab and clicked another it is starting to bounce. Open a new link in a new tab and close previous tab, stops jumping.

Seems weird XD
Comment 73 Marcia Knous [:marcia - use ni] 2007-02-19 12:58:43 PST
sion: Can you please reply with your build ID (type about: in the URL bar). I thought most of the people that were having that issue were hitting the "no bookmarks in the toolbar issue." Also, note any themes and extensions you have installed as well since I will try my best to repro this on Vista. thanks.

(In reply to comment #72)
> Marcia is right, im going to stop using Firefox for a while.
> 
> Bookmarks dont seem to affect my jumping, just happens randomly for me, when
> page is maximised or not, full size or not, loads of tabs 1 tab, bookmarks, no
> bookmarks.
> 
> I've had this problem before when installing certain themes on windows xp using
> windowsblinds, such as the emerance or w/e theme, made it jump.
> 
> im on vista atm and it jumps randomly, right now it isnt. and now i just closed
> 1 tab and clicked another it is starting to bounce. Open a new link in a new
> tab and close previous tab, stops jumping.
> 
> Seems weird XD
> 

Comment 74 sion 2007-02-19 15:44:54 PST
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.1) Gecko/2006120418 Firefox/2.0.0.1

Still doing it at random times. For example.

Open Up Firefox (not jumping)
load Hotmail (not jumping)
Login to hot mail (starts jumping)
go into inbox (jumping)
Click the email link for this page in new tab (stops jumping)
Close hotmail tab (starts jumping)
Comment 75 Carsten Book [:Tomcat] 2007-02-19 23:46:00 PST
sion: it was reported on http://forums.mozillazine.org/viewtopic.php?t=478782 that windows blind can also cause this problem.

Does this window shaking/jumping also occur when you turn off windows blind ?
Comment 76 sion 2007-02-20 01:18:53 PST
I dont know if windows blinds works on Vista, and I wouldnt use it on Vista anyway, but im on vista. I am not using windows blinds, I just stated that previously when I have had windows blinds it jumped on certain themes, but most like 9/10 I've tried, it didn't jump for me.

If I didn't have windows blinds, it never shakes, ever.
Comment 77 Marcia Knous [:marcia - use ni] 2007-02-20 16:19:47 PST
*** Bug 370969 has been marked as a duplicate of this bug. ***
Comment 78 Marcia Knous [:marcia - use ni] 2007-02-21 13:38:54 PST
*** Bug 364395 has been marked as a duplicate of this bug. ***
Comment 79 Adam Guthrie 2007-02-22 11:38:09 PST
*** Bug 371252 has been marked as a duplicate of this bug. ***
Comment 80 Ben 2007-02-22 15:40:27 PST
I can confirm this bug on Vista 32-bit, with my bookmarks toolbar folder empty. Very annoying.
Comment 81 sion 2007-02-22 15:49:52 PST
Weather it is empty or not, you will still get this.
Comment 82 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-02-22 16:05:38 PST
If you're seeing this and the bookmark toolbar is not empty, you're seeing a different bug (probably bug 221604).
Comment 83 Ben 2007-02-22 16:06:45 PST
Yes, I can confirm that I only get the bounce with the toolbar *empty*.
Comment 84 sion 2007-02-22 16:59:07 PST
Are you guys on Windows Vista?

I'm using Vista, I added bookmarks to toolbar and it still continues to bouce, but it isnt doing it as much :S maybe im tired.

I checked the site out Gavin, some of the dates go back along time, but I will have a thorough read. 

Thank you.
Comment 85 Merve 2007-02-23 09:12:11 PST
Yeap I am on Vista and I was so upset by the whole thing I just started using another browser while we figure out a fix. I tried everything,, even re-install!
Comment 86 sion 2007-02-23 09:33:43 PST
I was told by a friend to edit some stuff on the config (about:config) and that didnt fix it, nore did it mess it up any other way (or so i thought)

I did an reinstall cuse I hadn't tried to and I thought there was no point reinstalling if I never knew what the actual problem was.

I reinstalled and it still bounced, so starting from scratch I right click the bookmark area and add a book mark and it doesnt bounce no more.

I must of messed up my about:config? or maybe my vista is messed up a little because I had to do a repair as Nero for vista wouldn't work cuse of currupt install.

Cheers.
Comment 87 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-02-23 10:19:40 PST
There is no about:config setting that will fix this bug.
Comment 88 Sebastian Brocks 2007-02-28 11:43:13 PST
This is happening to me on Linux, too, when I drag the bookmarks toolbar items from the actual bookmarks toolbar to the top menu bar, right of the help menu, and then shrink the Firefox window so that it is so small that no bookmarks actually show up. When I enlarge it again so that at least one bookmark shows up, the bouncing stops.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.2) Gecko/20060601 Firefox/2.0.0.2 (Ubuntu-edgy)
Comment 89 Shaun Cummings 2007-03-01 13:42:34 PST
I noticed this happening after Firefox downloaded the 2.0.0.2 update.  I uninstalled Firefox and reinstalled a fresh copy (no customizations whatsoever) and the problem continued.  I only use Firefox as a testing platform, so I pretty much stick with the defaults (except for making it automatically dump its cache/cookies/etc and not save browser history) and therefore my bookmarks toolbar is empty, as described above, but has not been moved from it's default location (below the navigation toolbar).

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Description:  Vista x64 Ultimate (fully patched).
Background Processes (other than standard Windows components):
  Kaspersky AV 6.0.2.614 (fully patched)
  uTorrent 1.6.1
  Virtual DAEMON Manager V4.08HE
  ATI Catalyst Control Center 7 (0122.1848.2579.33475)
Comment 90 w4zsvryct5gx7nf 2007-03-02 04:13:07 PST
Please note that this is not platform or OS dependent, this should not be assigned to PC/Windows. I get it on all different OSs.
Also, the Bookmarks Toolbar needs not be "empty", if the window is too small to fit any bookmarks in the toolbar, this still happens.
It also doesn't need to be placed right to the menu bar, happens when it's in the default location, too. Please change the title.
Comment 91 Muthusrinivasan 2007-03-09 06:27:28 PST
same here 
if u delete the bookmark and the live news ,it happens like that then i added show book marks icon from the toolbar ( customize ) it works normally
Comment 92 Barend 2007-03-09 09:32:34 PST
I twould suggest that the status of this bug should be at least normal, not minor, since it is very visible, and completely inhibits the use of firefox by the bug's "victims".
Comment 93 Marcia Knous [:marcia - use ni] 2007-03-16 16:30:47 PDT
*** Bug 374273 has been marked as a duplicate of this bug. ***
Comment 94 Dave Townsend [:mossop] 2007-03-16 17:12:50 PDT
Created attachment 258855 [details] [diff] [review]
patch rev 1

Extremely simple fix. If there are no bookmarks in the toolbar, then collapse the chevron and bail. This stops the resize loop.

This patch is against trunk, but the same fix will work against branch which is where ideally this could go to.
Comment 95 Dave Townsend [:mossop] 2007-03-16 17:40:47 PDT
Created attachment 258860 [details] [diff] [review]
patch rev 2

Per discussion on IRC, clear _overflowTimerInEffect at the start of resizeFunc to cover all early return cases.
Comment 96 Deidre 2007-03-18 11:29:12 PDT
I was having this same problem, and it was driving me crazy. I really didn't want to have to go back to IE. But look at this logically... If it was working before we deleted the links out of the 'Bookmarks Toolbar Folder', and it started screwing up after that, the solution is clear. Just put some links back in the folder, and put it back in its original location in the drop down menu. They don't have to be the same ones that were deleted, and you don't have to switch back to Windows Classic. I'm on Vista, and it's working fine for me. I've gone through all my links, and not a single jumping page since I've replaced the links. I've minimized windows, reopened, and opened new tabs. Everything's fine. 
Comment 97 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-03-18 16:12:54 PDT
Comment on attachment 258860 [details] [diff] [review]
patch rev 2

Ideally we could, in addition to this, do something like the first patch, to avoid the "jump" when adding a bookmark to a blank bookmark toolbar, but the unpredictability of the native theming code means that any min-height value we'd hard code would be a hack. Thanks for taking this.
Comment 98 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-03-19 18:15:42 PDT
mozilla/browser/components/bookmarks/content/bookmarksMenu.js 	1.57
Comment 99 Dave Townsend [:mossop] 2007-03-24 15:22:12 PDT
Created attachment 259537 [details] [diff] [review]
Branch version of patch

This is an identical patch but against branch so carrying over review.

Pretty much no risk as far as I'm concerned and would resolve a fairly popular support issue.
Comment 100 Robert Longson 2007-03-26 05:13:46 PDT
*** Bug 375377 has been marked as a duplicate of this bug. ***
Comment 101 Daniel Veditz [:dveditz] 2007-03-27 15:56:20 PDT
Comment on attachment 259537 [details] [diff] [review]
Branch version of patch

approved for 1.8.0.12/1.8.1.4, a=dveditz for release-drivers
Comment 102 Dave Townsend [:mossop] 2007-03-30 15:44:40 PDT
*** Bug 376050 has been marked as a duplicate of this bug. ***
Comment 103 Steve England [:stevee] 2007-03-31 04:32:40 PDT
*** Bug 376080 has been marked as a duplicate of this bug. ***
Comment 104 Phil Ringnalda (:philor) 2007-03-31 20:28:47 PDT
*** Bug 376132 has been marked as a duplicate of this bug. ***
Comment 105 Phil Ringnalda (:philor) 2007-04-01 16:36:52 PDT
browser/components/bookmarks/content/bookmarksMenu.js: 1.48.2.6.2.1
Comment 106 Phil Ringnalda (:philor) 2007-04-02 20:03:55 PDT
browser/components/bookmarks/content/bookmarksMenu.js: 1.48.2.10
Comment 107 Adam Guthrie 2007-04-05 11:28:08 PDT
*** Bug 316190 has been marked as a duplicate of this bug. ***
Comment 108 Mats Palmgren (:mats) 2007-04-07 08:34:01 PDT
*** Bug 376778 has been marked as a duplicate of this bug. ***
Comment 109 simon 2007-04-10 16:15:38 PDT
I"m Having problems installing fire fox Update,It keeps asking to install every time I go on the internet and doesn"t install ,Just repeats every time
Comment 110 -fullmetaljacket- 2007-04-11 18:11:26 PDT
(In reply to comment #109)
> I"m Having problems installing fire fox Update,It keeps asking to install every
> time I go on the internet and doesn"t install ,Just repeats every time
> 

what version of firefox are you currently using? what you might seeing is bug 351949

Comment 111 simon 2007-04-11 21:18:30 PDT
The version of Fire fox ,its trying to install is Firefox 2.0.0.3
Comment 112 Dave Townsend [:mossop] 2007-04-14 13:05:15 PDT
*** Bug 377508 has been marked as a duplicate of this bug. ***
Comment 113 simon 2007-04-14 16:01:01 PDT
(In reply to comment #112)
> *** Bug 377508 has been marked as a duplicate of this bug. ***
> 
So is that Problem Solved Now,I may Have send you an email,Just ignore it,simon,thankyou
Comment 114 Phil Ringnalda (:philor) 2007-04-18 17:42:59 PDT
*** Bug 377974 has been marked as a duplicate of this bug. ***
Comment 115 simon 2007-04-18 18:52:40 PDT
(In reply to comment #114)
> *** Bug 377974 has been marked as a duplicate of this bug. ***
> 

Comment 116 simon 2007-04-18 18:55:13 PDT
(In reply to comment #115)
> (In reply to comment #114)
> > *** Bug 377974 has been marked as a duplicate of this bug. ***
> > 
> Still Have problem with firefox,Still Repeating installed Updates

Comment 117 Phil Ringnalda (:philor) 2007-04-18 19:21:20 PDT
Simon: this bug has absolutely nothing to do with repeated updates, and Bugzilla is the wrong place to look for user support. Please use http://forums.mozillazine.org/viewforum.php?f=38 instead.
Comment 118 Steve England [:stevee] 2007-04-21 14:06:05 PDT
*** Bug 378311 has been marked as a duplicate of this bug. ***
Comment 119 Carsten Book [:Tomcat] 2007-04-23 03:10:59 PDT
*** Bug 376838 has been marked as a duplicate of this bug. ***
Comment 120 Marcia Knous [:marcia - use ni] 2007-05-08 11:38:39 PDT
verified fixed on the 1.8 branch using  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.4pre) Gecko/2007050804 BonEcho/2.0.0.4pre. I tested with Win Vista Home Basic. No bounces or shakes observed. I also checked on Mac as well, since this bug was cross platform, and things look good there as well. adding branch keyword.
Comment 121 Stuart Smith 2007-05-09 10:48:36 PDT
*** Bug 380166 has been marked as a duplicate of this bug. ***
Comment 122 Phil Ringnalda (:philor) 2007-05-12 20:47:27 PDT
*** Bug 380544 has been marked as a duplicate of this bug. ***
Comment 123 Jay 2007-05-14 20:19:30 PDT
well in my case it has nothing to do with the bookmarks/tool bars, even typing in a web address and the damn page constantly bounces it's annoying, has anyone actualy got a fix for this instead of having to read thru every line in which gives no indecation of a fix just indecates more problems
Comment 124 Adam Guthrie 2007-05-17 13:18:18 PDT
*** Bug 333885 has been marked as a duplicate of this bug. ***
Comment 125 Adam Guthrie 2007-05-17 17:49:31 PDT
*** Bug 334108 has been marked as a duplicate of this bug. ***
Comment 126 Carsten Book [:Tomcat] 2007-05-20 16:06:39 PDT
*** Bug 319016 has been marked as a duplicate of this bug. ***
Comment 127 Carsten Book [:Tomcat] 2007-05-28 09:15:53 PDT
*** Bug 382232 has been marked as a duplicate of this bug. ***
Comment 128 Carsten Book [:Tomcat] 2007-05-28 09:16:41 PDT
verified fixed 1.8.0.12 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US;
rv:1.8.0.12) Gecko/20070508 Firefox/1.5.0.12 with the steps to reproduce from
this bug and the Mozillazine KB Article.

No window bounce/shake/jump -> adding verified keyword
Comment 129 Samuel Sidler (old account; do not CC) 2007-05-31 21:12:48 PDT
*** Bug 376140 has been marked as a duplicate of this bug. ***
Comment 130 Salvatore LaFata 2007-06-04 05:56:50 PDT
I wouldn't consider this issue resolved.  My wife just upgraded Firefox to version 2.0.0.4 and started getting the shakes described in this bug, which didn't exist before.  Her bookmarks toolbar is enabled and has bookmarks in it.  She also has the Yahoo Toolbar installed.  If she uses the default theme, then she doesn't experience the shakes.  If she uses the Pink Paula theme, then she gets the shakes.  Nothing else has changed.  I'm not sure if this issue has to do with the Pink Paula theme or not, but the description is exactly what happens on her laptop.
Comment 131 Dave Townsend [:mossop] 2007-06-04 06:05:12 PDT
(In reply to comment #130)
> I wouldn't consider this issue resolved.  My wife just upgraded Firefox to
> version 2.0.0.4 and started getting the shakes described in this bug, which
> didn't exist before.  Her bookmarks toolbar is enabled and has bookmarks in it.
>  She also has the Yahoo Toolbar installed.  If she uses the default theme, then
> she doesn't experience the shakes.  If she uses the Pink Paula theme, then she
> gets the shakes.  Nothing else has changed.  I'm not sure if this issue has to
> do with the Pink Paula theme or not, but the description is exactly what
> happens on her laptop.
> 

This bug is about the shaking occurring when the bookmarks toolbar is empty so what you are seeing is clearly different, possibly bug 178884. If it is not that I would suggest either consulting with the Pink Paula theme author or filing a new bug.
Comment 132 Phil Ringnalda (:philor) 2007-06-05 14:30:44 PDT
*** Bug 335357 has been marked as a duplicate of this bug. ***
Comment 133 Marcia Knous [:marcia - use ni] 2007-06-05 15:52:46 PDT
*** Bug 362618 has been marked as a duplicate of this bug. ***
Comment 134 william selmi 2007-06-16 21:48:27 PDT
(In reply to comment #1)
> dupe of bug 254990 (although I realized this one was filed first)
> 

I'm using firefox 2.0.0.4. Every time I boot up it wants to install 2.0.0.4 again. I say "later". As part of this problem, I think, my screen bounces or shakes when I go from page to page. Any idea what this is?

Bill 
Comment 135 J 2007-06-23 01:27:48 PDT
I'm using Mozilla Firefox 1.5.0.8 (jus updated to 1.5.0.12) and ever since I have installed the browser, it starts this action of jumping/dancing/shaking and just does not stop. even tabs act similarly. it stabilises for a a few seconds when I want to attach a file in emails, but after I am done attaching it starts this weird behaviour all over again. Help! 
On Windows XP SP2 and no themes installed, only a google toolbar. 


June 
Comment 136 J 2007-06-23 01:33:25 PDT
Windows XP Professional* SP2. there! its begun shaking again :( 
This is a fresh install after I uninstalled Firefox 2.0 thinking there was something wrong with the browser. However, 1.5.0.8 shows the same bouncing up and down behaviour as I write this.

23 June 2007 
Comment 137 Dave Townsend [:mossop] 2007-06-26 07:55:53 PDT
Created attachment 269862 [details] [diff] [review]
places version of patch

This is an equivalent patch applied to the places bookmarks toolbar.
Comment 138 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2007-06-26 15:35:29 PDT
Comment on attachment 269862 [details] [diff] [review]
places version of patch

r=mano.
Comment 139 Dave Townsend [:mossop] 2007-06-26 18:13:50 PDT
Checking in browser/components/places/content/toolbar.xml;
/cvsroot/mozilla/browser/components/places/content/toolbar.xml,v  <--  toolbar.xml
new revision: 1.94; previous revision: 1.93
done
Comment 140 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2007-06-29 17:55:11 PDT
*** Bug 386292 has been marked as a duplicate of this bug. ***
Comment 141 william selmi 2007-06-29 18:06:46 PDT
I fooled around with the toolbars and wound up with, from top to bottom, nav., bookmarks and Google and that seemed to do it. Keeping my fingers crossed.
Comment 142 Worcester12345 2007-07-09 14:44:53 PDT
Jason, as bug reporter, can you verify?
Comment 143 ryan 2007-07-23 16:56:33 PDT
whats up with this non working script message? whenever I go onto any YouTube channel this pops up:
a script on this page may be busy, or it may have stopped responding. you can stop the script now, or you can continue to see if the script will complete.
LAME!!! Help me immediately.. not as a threat to you.. but im thinking about going back to Internet Explorer..
Comment 144 Stephen Donner [:stephend] - PTO; back on 5/28 2007-08-18 23:46:08 PDT
(In reply to comment #143)
> whats up with this non working script message? whenever I go onto any YouTube
> channel this pops up:
> a script on this page may be busy, or it may have stopped responding. you can
> stop the script now, or you can continue to see if the script will complete.
> LAME!!! Help me immediately.. not as a threat to you.. but im thinking about
> going back to Internet Explorer..

That has absolutely nothing to do with this bug.

Please see http://kb.mozillazine.org/Script_busy_or_stopped_responding

Comment 145 bhaskar 2008-08-28 11:40:00 PDT
it's shakeing again in firefox 3.0.1
Comment 146 Mardeg 2008-11-18 02:04:22 PST
*** Bug 451490 has been marked as a duplicate of this bug. ***
Comment 147 William Bumgarner [:zsinj] 2009-01-19 08:30:23 PST
*** Bug 255342 has been marked as a duplicate of this bug. ***
Comment 148 Mycroft Project (CC) 2009-03-16 12:09:44 PDT
*** Bug 358749 has been marked as a duplicate of this bug. ***
Comment 149 Daniel.S 2009-05-01 08:57:43 PDT
*** Bug 488002 has been marked as a duplicate of this bug. ***
Comment 150 Alan 2009-05-24 07:26:09 PDT
This issue is not "fixed"  Ever since Firfox (Firefox/3.0.10) was released I periodically have the constant jumping up and down.  I have checked my video card and drivers and can find nothing wrong.  With the thousands of people reporting this problem I would think Mozilla would take a better look at this.  I like Firefox but it looks like I may have to switch back to IE.
Comment 151 Gerry 2009-06-24 19:26:18 PDT
Using 3.0.11. My bookmarks toolbar is not empty but it is placed in the top right of the menubar and exhibiting the same symptoms. This very page is twitching right now.
Comment 152 dqmot17 2009-07-18 14:22:04 PDT
I got the jumping when i first upgraded to 3.5.1 and clicked "Release Notes" on the Mozilla page
Comment 153 minelli.kate01 2009-08-26 08:58:24 PDT
The problem still exists in 3.0.13.  It's not fixed.
Comment 154 u88484 2009-08-26 09:10:43 PDT
(In reply to comment #153)
> The problem still exists in 3.0.13.  It's not fixed.

For workarounds, see http://kb.mozillazine.org/Window_shakes

and how about when using Firefox 3.5.2.  Also, open a new bug if you can confirm that this problem exists using the latest firefox (3.5.2) and if you can reproduce this problem with your extensions disabled.
Comment 155 albertreus 2009-10-13 08:32:43 PDT
My tollbar is http://riyac.ourtoolbar.com/ and don't works.
Comment 156 Kevin Brosnan 2010-04-22 04:46:12 PDT
*** Bug 328837 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.