Right-clicking / downloading an extension saves confusing filename

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: Frank Fridlund, Assigned: wolf)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When right-clicking on a Thunderbird extension and selecting "Save link to
disk", it defaults to saving the file as "install.php" instead of
(filename).xpi.  It should offer the correct filename

Reproducible: Always
Steps to Reproduce:
(Assignee)

Comment 1

14 years ago
Confirmed... looks like I need to add a content-disposition header, or the like..

In all reality I need to attempt to force the browser to download the extension,
but i'm not sure I can. :-/

Though i'm surprised the Extension Manager doesn't think it's /installing/
index.php in firefox. 
Assignee: nobody → psychoticwolf
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED

Comment 2

14 years ago
Yeah, need to set it to generic binary for downloading.  We do this on ER, I
believe.
(Assignee)

Comment 3

14 years ago
humm.. well, because of the way the site uses the ftp mirrors, nothing I can do
about forcing download without killing bandwidth on the site dead. heh. Figured
this was the case.

Content-Disposition isn't the problem, the bug is actually in the way the save
link as... dialog works.. Fortunately, Silver suggested a nice workaround that
works. :-) (Thanks Silver!) 

Fix will be posted shortly... 
(Assignee)

Comment 4

14 years ago
This is now fixed. :-) Thanks for reporting it.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Summary: Right-clicking on a Thunderbird extension saves confusing filename → Right-clicking / downloading an extension saves confusing filename
(Reporter)

Comment 5

14 years ago
Yeah, I can verify it.  Marking verified.
Status: RESOLVED → VERIFIED

Comment 6

14 years ago
do we need to file a seperate bug about the save as dialog, so we can track it
(even if it's not our fault?)
(Assignee)

Updated

14 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
(Reporter)

Comment 7

14 years ago
Repoening bug, as it still happens for Thunderbird extensions.  Possibly
depending on bug 279413
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 8

14 years ago
Were you looking at the live site?  This is fixed in our development
environment.  This is how all Mozilla applications are treated.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.