Need automated check when new files are added

VERIFIED DUPLICATE of bug 24398

Status

P3
normal
VERIFIED DUPLICATE of bug 24398
19 years ago
10 years ago

People

(Reporter: paulmac, Assigned: Chris.Yeh)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
There has got to be a better way than depending on developers to update the dist
file when adding new files. I've seen two fairly responsible developers fail to
do this in the last two days, one of them causing major hoarkage on Mac and Windows.

At the very least, some type of automated script that does a diff every night
and checks for new files, and then notifies the appropriate people.

I have to guess there are files right now that aren't in the dist, but we don't
know because they aren't as severe as the hang on start-up problems we saw
earlier this week. And apologies if this is already being taken care of.

Comment 1

19 years ago
There is another bug filed on me to do this. I have several problems with the
proposal you make... mostly with the phrase ``notify the appropriate people.''
Who are the appropriate people? I can't get to this right now, or in the near
future. I know, i hate relying on people being aware of newsgroup postings, 
reminders in meetings, and email to internal mailing lists.

*** This bug has been marked as a duplicate of 24398 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

19 years ago
Okay, I'm not saying people shouldn't be doing all those things (reading 
newsgroups, etc). I'm just looking at the end result and noting that the current 
method is not a catch-all and something else needs to be done. There has to be a 
safety net.

Marking as verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: Installer: XPI Packages → Installer
QA Contact: agracebush → general
You need to log in before you can comment on or make changes to this bug.