Closed Bug 247805 Opened 18 years ago Closed 17 years ago

Popup windows show transparent backgrounds when options>fonts are colors are set to "always use my colors"

Categories

(Firefox :: General, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 255411

People

(Reporter: d2ogilvi, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

This bug occurs when popup windows are used in onmouseover(popup...) in a shape
statement in html, but only if the "use my colors" option is set in preferences.
 This is most noticable if the windows color scheme is set to "High Contrast
Black", but also occurs wirth the "Windows Standard" color scheme as well.

This is confirmed to happen in Windows 95, 98SE, XP Home and XP Pro (I can't
verify for NT or 2000).  I'll provide URLs of other websites that this happens
in later on in the bug.

Reproducible: Always
Steps to Reproduce:
1. In FireFox, go to Tools>Options>General>Fonts and Colors
2. Set "Always use my" "Fonts" to "checked"
3. Save settings.
4. Browse to:
http://www.weatheroffice.ec.gc.ca/warnings/warnings_e.html
or
http://www.intellicast.com/Local/USLocalWide.asp?loc=kgrb&seg=LocalWeather&prodgrp=SevereWeather&product=RadarSummary&prodnav=none
5. Move mouse over provinces in first web page or over menus in second web site

Actual Results:  
The popup windows containing the province names or menu items are transparent,
making them difficult to see.  This is even more evident when you change the
Windows color scheme to "High Contrast black", as the popups show white text on
the transparent background, often on a white area of the website... particularly
in the first website noted above.

Expected Results:  
I feel that the popups should have a background and text colors that reflacts
the Windows colour scheme (white background and black text when in "Windows
Standard" color scheme and white text on a black background when in "High
Contrast Black" color scheme.

This bug has existed since Netscape 3 (and has probably always existed)

I'm not sure the exact html code that is bringing up the transparent menus in
the second web site.

I also noticed the same behaviour in the bugzilla page when "helpful tool tips"
is on... the tool tips also come up transparent.

This is mainly an accessibility issue.
*** Bug 247806 has been marked as a duplicate of this bug. ***
See bug 205892 and bug 255411 

*** This bug has been marked as a duplicate of 255411 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.