no option to disable new windows unless explicitly requested

RESOLVED DUPLICATE of bug 227241

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 227241
14 years ago
14 years ago

People

(Reporter: Nick Pilon, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Firefox does not completely support tabbed browsing. There should be an option
integrated with the browser to open ALL new windows in tabs. (With background or
foreground decided by the usual config option) With this option enabled, it
should ONLY be possible to open new windows explicitly. (VIA File->New Window or
Context->Open Link in New Window) Firefox should do the same thing when other
programs attempt to open a link using it.

Reproducible: Always
Steps to Reproduce:
Problem #1:
1. Enable tabbed browsing.
2. Go to a page that opens a new window in respsonse to a click on a link or
automatically, VIA javascript, external links, or any other mechanism.
3. Click on one of these links, if necessary.

Problem #2:
1. Set firefox as the http/HTML handler for other programs.
2. Open a link in one of these programs.
Actual Results:  
A new window opened.

Expected Results:  
The "new window" should have opened in a tab in the same browser window or the
most recent browser window. (If opening from another program)

*** This bug has been marked as a duplicate of 227241 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.