Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 248235 - Mute option so that browser process emits no sound
: Mute option so that browser process emits no sound
Status: RESOLVED DUPLICATE of bug 24418
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- enhancement with 23 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: 259557 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2004-06-22 18:33 PDT by Ali Ebrahim
Modified: 2010-01-31 13:01 PST (History)
7 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Ali Ebrahim 2004-06-22 18:33:37 PDT
With so many flash sites making noise, and even worse, today's crop of video
advertisements, it would be good if Firefox could implement an option to mute
the browser process, so that the browser process would always remain silent if
this option was enabled.

It could be another selling point over Internet Explorer.
Comment 1 Ali Ebrahim 2004-06-22 20:13:59 PDT
The equivalent Seamonkey bug is bug 24418.
Comment 2 Jo Hermans 2004-09-15 07:20:49 PDT
*** Bug 259557 has been marked as a duplicate of this bug. ***
Comment 3 slice1900 2004-12-30 13:23:07 PST
In bug #24418 for Mozilla there is a lot of discussing about disabling audio for
various types of media or plugins.  While that'd be nice to have, what would be
really cool right now is to just have that little speaker icon we are all used
to down in the status bar that we can click on to mute or unmute, which controls
all sounds coming out of the browser and its plugins (if it is hard to do for
them all, doing them for a subset and fixing the others later is better than

Is this something that's fairly easy or is it hairy?  If some object to having
more stuff in the GUI (more icons slowing down the browser) then perhaps a
hidden pref changeable in about:config that enables the speaker icon would
satisfy those of us who hate browsing around and having an ad start blaring
music or stupid talk at us a minute or two after reaching the site....I notice
such annoying ads rarely start with the sound right away because the site owners
know that people would be annoyed and leave the site if it started up immediately!
Comment 4 Matthias Versen [:Matti] 2005-05-08 15:27:04 PDT
You can only disable the whole plugin but not for example only the sound in flash.
Comment 5 Jo Hermans 2010-01-31 13:01:41 PST
bug 24418 is no longer SeaMonkey-only

*** This bug has been marked as a duplicate of bug 24418 ***

Note You need to log in before you can comment on or make changes to this bug.