Patching of new versions of mozilla to decrease bandwidth required

RESOLVED WORKSFORME

Status

SeaMonkey
Build Config
--
enhancement
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: Josh Heidenreich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [SmBugEvent])

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031212

If new versions of Mozilla were patchable (both nightly builds and releases)
people on slowwer connections (such as 28k modem) are not waiting for ages to
downlaod the latest nightly build becasue they would just be downloading the patch.

This would also increase the number of people with upto-date nightly releases
because we (people on slow connections) would update more often.

This also saves bandwidth at both ends of the connection

Reproducible: Always
Steps to Reproduce:
1. Start downloading the latest Nightly build
2. Wait for ages
3. Get kicked off net by isp because it takes to long
4. Repeat steps 1-3.
Actual Results:  
Ended up with an old version of mozilla and little money

Expected Results:  
Downloaded the Mozilla Patch for a nightly build in 10 minuites or less,
installed the patch and have an upto date version of Mozilla.

In the future a auto-patcher could be added

Comment 1

14 years ago
This probably dups to bug 51998 or bug 116722.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> This probably dups to bug 51998 or bug 116722.

Only the last comment. the rest (patching) would not

I really hope this will happen coz its 53% of the latest nightly and thats been
running for the last hour, six minuites and 48 seconds (on my 28k modem) and
patching will reduce thet time quite a bit

Comment 3

14 years ago
Against what previous build patch should be? What should happen, when you'll
have older version? What to do, if some file (not in your profile) was modified
by extension?
(Reporter)

Comment 4

14 years ago
there are many options of when to patch from. You could patch from the last 
milestone build or you could have mini-milestones every week or so.

The source tree will not be closed for mini-milestones. Patches patch from the 
last mini-milestone. If you fall behind you just get the latest mini-milestone 
(that could also patch from the latest milestone build)

If a file was modified by an extention it would be copied to the users profile 
and then the new file would overwrite the old file. You could then have code 
in place that will use a file from the users profile instead if it exists. (it 
would depend on the file of course)
Product: Browser → Seamonkey

Comment 5

13 years ago
like Bug 296868 - FF Software Update Service?

Confirming. Where to put it though?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #5)
> like Bug 296868 - FF Software Update Service?
> 
> Confirming. Where to put it though?

I suggest Build Config (build partial .mar in addition to full .mar).
Please resolve WFM (or dupe) if partial .mar files are already being built for SeaMonkey.
Assignee: general → nobody
Component: General → Build Config
QA Contact: general → build-config
Whiteboard: [SmBugEvent]

Comment 7

7 years ago
WFM.
Partial .mar's have been around in SeaMonkey for a good old while now.

Comment 8

7 years ago
Created attachment 533776 [details]
Screenshot, full & partial .mar
WFM according to comment #7 and #8.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.