When I click on a link from an email in Outlook, it attempts to open an ".exe file"

RESOLVED DUPLICATE of bug 246078

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 246078
14 years ago
13 years ago

People

(Reporter: Jeremy, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME (DDE))

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When I click on a link from an email in Outlook, it attempts to open an ".exe
file".  It opens the website as well, but it also trys to open a .exe file from
My Documents.  Any ideas?  Thanks.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Could be bug 246078 in disguise.

Comment 2

14 years ago
I am also running into this bug.  Very annoying.

Comment 3

14 years ago
Confirmed - all the links get opened twice! :-(

Comment 4

14 years ago
Same here.  It asked for the .exe file and now opens each link from email twice.

Comment 5

14 years ago
Happens on W2K, too.  And it also happens in Word, or probably any MS Office
application.  What comes up in Outlook is a "Locate Link Browser".  You can get
it manually by shift-clicking a link in Outlook.  If you point it at
Firefox.exe, which is what it wants, it will then open a clicked link twice in
Firefox (in a new window, though I have an extension so mine opens in a second
tab instead).

Without knowing any of the actual code behind Firefox or the Microsoft products,
it "feels" to me like Outlook tries to launch the link, Firefox gets it, but
somehow Outlook doesn't get the signal that it hit correctly, so it tries
another method to launch the link in a browser.  Of course, I could be way off.

My personal quick-fix was to create a custom nop.exe ("null-op", null operation)
in Visual Basic which does absolutely nothing; you launch nop.exe, and it ends
immediately.  Then I pointed that "Locate Link Browser" dialog to launch
nop.exe.  Now Outlook's first hit still goes through and opens the link in
Firefox (being the default browser), but it fires the second request to nop.exe,
which happily ignores it and ends, so no second page is opened.

If anybody wants nop.exe, I'll happily send it to you free.  And/or the Visual
Basic project, if you care.  0213_bug@danblack.org

If any Mozilla programmers want screen shots of the error (like the "Locate Link
Browser" bit), I'd be happy to send that, too.  0213_bug@danblack.org

Comment 6

14 years ago
Created attachment 153314 [details]
"Locate Link Browser" dialog from Outlook

Ah, didn't see the place to add attachments.  I'm including two screenshots,
first the "Locate Link Browser" dialog that Outlook brings up, and second an
example of clicking the link (just a single-click).  Brings up the same link
twice.	Usually does it in two windows; I have an extension that does it in a
second tab instead, which I thought made it easier to see in a screenshot
anyway.

Comment 7

14 years ago
Created attachment 153315 [details]
one click on the link, two windows/tabs result

Comment 8

14 years ago
Yes, all the MS 2003 office applications open 2 browser windows when a link is
clicked. Is there a fix for this that I'm missing?

Comment 9

14 years ago
I would like to confirm the opening of two firefox browsers when clicking on one
link within Outlook 2002 Sp2 on Windows XP.

Comment 10

14 years ago
Sounds like a similar bug I am experiencing.  When I attempt to open a link from
an email in Outlook, the Install Wizard for APC Power Chute starts.  The window
for the link opens, but I have to cancel the Install Wizard each time.

Comment 11

14 years ago
I too am experiencing this problem.

Comment 12

14 years ago
cf: bug 253635 and bug 254956

Comment 13

14 years ago
I have created a quick website with the work around bowred from Dan Black.
http://www.geocities.com/griffis_8/

Comment 14

14 years ago
As mentioned in comment #1, this may be a duplicate of bug 246078.  Applying
this fix for bug 246078:

http://johnhaller.com/jh/mozilla/firefox_bug_246078.asp

fixes the "Locate Link Browser" behavior in my setup (Windows 2000, Firefox 0.9.3).

Comment 15

14 years ago
Correction to comment 14:  Firefox version 0.9.1, not 0.9.3.

Comment 16

14 years ago
*** Bug 254956 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Whiteboard: DUPEME (DDE)
<-DUPE-246078 as per comment #15.

*** This bug has been marked as a duplicate of 246078 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.