If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

notify arbitrary components at startup

VERIFIED FIXED in M15

Status

Core Graveyard
Tracking
P3
normal
VERIFIED FIXED
18 years ago
a year ago

People

(Reporter: Alec Flett, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({verifyme})

Trunk
x86
Linux
verifyme

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
per #11185, we should allow an arbitrary component to get command line
arguments.

The functionality already exists for actually retrieving the command line (via
the nsICmdLineService, so what we need is a way for an application to be
notified at boot time that the app has started, so it can process any
startup-oriented command lines, such as -chatzilla or something

my proposal would be to use the category manager. During registration (using the
Generic Module reg/unreg hooks) components could register CIDs in the category
manager as "startup components" and then during startup, we'd enumerate all the
members of that category, and initialize them.

This is almost exactly how the appshell components work (mozilla/xpfe/appshell)
except that the appshell components are hardcoded to some wierd place in the
registry. Once this facility exists, we should convert the appshell components
as well.
*** Bug 24875 has been marked as a duplicate of this bug. ***
marking m16
Status: NEW → ASSIGNED
Target Milestone: M16

Updated

18 years ago
Blocks: 11185
I'm waiting for scc to land his new implementation of the category manager.

right now, I can't access it from C++.

but I'm getting all the pieces together in my local tree, so once he does land,
I'll be close to landing.
Target Milestone: M16 → M14
this works now.  next step is to do the work for -chat and -aim and -remote
will do -aim and -chat and -remote in m15.
Target Milestone: M14 → M15
this is fixed, and got fixed a while ago.

I'll create new bugs for -chat.

a bug already exists for -remote.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Adding verifyme keyword.
Keywords: verifyme

Comment 8

18 years ago
verified -aim with windows and linux builds of 20000315 beta bits.

Comment 9

18 years ago
oops I meant 20000313 beta bits

Comment 10

18 years ago
Marking Verified per testers comments.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.