allow arbitrary command line arguments to be handled (like -aim)

VERIFIED DUPLICATE of bug 24870

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 24870
19 years ago
14 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

automatically moving this bug from bugsplat to bugzilla failed.

so I'm doing it by hand.

here's the bugsplat log:

right now, we don't support the -aim command line argument to launch just aim in
5.0



------- Additional Comments From amusil  Oct-28-1999 14:47 ------- 

Is this a Linux only option or Windows as well?


------- Additional Comments From sspitzer  Oct-28-1999 15:13 ------- 

it would on all three platforms.

on mac, to exercise it, we'd have a "Mozilla AIM" file that had one line,
args:-aim

see mozilla/xpfe/bootstrap/Mozilla_Editor for an example.


------- Additional Comments From syd  Dec-24-1999 13:57 ------- 

will need to move xpfe/bootstrap over into the ns tree in order to accomplish
this, no problem.

------- Additional Comments From amusil  Jan-11-2000 15:43 ------- 

I'll take a look at this


------- Additional Comments From amusil  Jan-12-2000 16:44 ------- 

This can already be achieved by:

mozilla.exe -chrome chrome://aim/content/App.xul

does this work OK for you?  Is there a way (w/o having to modify C++ code) to 
make -aim equivalent to this?

------- Additional Comments From amusil  Jan-20-2000 16:12 ------- 

Reassigning to sspitzer as per our conversation.
this used to be bug http://scopus/bugsplat/show_bug.cgi?id=368159

adding travis to the cc list.

the whole point of this bug is we won't be hard coding each command line
argument, we'll be using XPCOM to accomplish this.
QA Contact: nobody → prass

*** This bug has been marked as a duplicate of 24870 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
veryfying as dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.