Password asked every startup/on first change after startup

RESOLVED INVALID

Status

Calendar
Provider: ICS/WebDAV
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Michael, Unassigned)

Tracking

Trunk
x86
Windows 2000

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

I just switched to mozilla 1.7 and installed the nightly (2004-06-22) 1.7 build.
 I am syncing my calendars with an online webDAV server.  However, mozilla has
stored my password, but a dialog pops up everytime I start up Calendar.  It has
the correct password already entered in the dialog and also has the store
password checked.  It seems to remebers the password, but is always asking
everytime I start it up.  I'm pretty sure it never did this before. 

Reproducible: Always
Steps to Reproduce:
1. Start Up Calendar.   (Set Reload Calendar on startup)
2. Subscribe to online iCal (password protected)
3. Enter password, check store password.
4. Restart Calendar

Actual Results:  
Dialog asking password popped up again.

Expected Results:  
No dialog box, password correct stored and entered.

This is my first bugzilla bug report.  I searched through exisiting bugs and
none seemed to fit this.  It also seems to be a annoying behavior category, not
really a big.  Thanks

Comment 1

14 years ago
I've seen this too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is basicly bug 117592
Depends on: 117592

Updated

12 years ago
QA Contact: gurganbl → general

Comment 3

12 years ago
This is an absolute show stopper for a group that has 10+ calendars. Who is going to enter the same user/pass 10+ times every time they launch Calendar?


Sunbird 0.3a1 and 0.3a1+

Sunbird will not utilize user/pass arguments that are directly entered into the location for the subscribed calendar.


Background:
WebDAV shared directory.
7 mac users using iCal from Apple. 2 Sunbird users trying to join in.


In Sunbird, subscribe to remote calendar. 
Choose remote radio button, then next. 
Format WebDAV, and in the location box enter
"http://cal_read:calcal@somebox.somewhere.int/calendarDAV/somebodycalendar.ics"

During the current Sunbird session, this works just fine.
I go and edit the subscribed calendar entry and check the read-only box.

Exit from Sunbird and relaunch later. It pops up a dialog demanding the password for the calendar realm that was hard-coded into the location path!
I have to manually re-enter the same password for each and every subscribed calendar. Sometimes twice. This is an absolute show stopper for a group that has 10+ calendars. Who is going to enter the same user/pass 10+ times every time they launch Calendar?

I have two users for the webDAV directory: one user cal_read, who has read-only access to the
entire directory. And a second user cal_write who has write access to the whole directory. I
put cal_read in the location box of the subscribed calendars and use cal_write for the one
calendar each user publishes.


I manually put the user/pass into the location for the calendar. I'm not utilizing the password manager. Why doesn't Sunbird honor it?
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
*** Bug 349678 has been marked as a duplicate of this bug. ***
Severity: minor → normal
Component: General → Provider: ICS/Webdav
QA Contact: general → ics-provider
Summary: Password asked every startup → Password asked every startup/on first change after startup
Version: unspecified → Trunk

Comment 6

10 years ago
Similar Bug 343721 and Bug 258524 was fixed some time ago.

Michael, same, Johannes: Does the issue still exists using a recent nightly test build of Sunbird 0.7pre? <http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-mozilla1.8/>

Comment 7

10 years ago
I can't reproduce it using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9pre) Gecko/20071103 Calendar/0.8pre, but trunk (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007110401 Calendar/0.6a1) doesn't allow me to access the calendar. It shows: 
Error: Components.classes['@mozilla.org/passwordmanager;1'] has no properties
Source File: file:///C:/Documents%20and%20Settings/Omar/Pulpit/Sunbird%20trunk/js/calUtils.js
Line: 711

I'm trying to access http://mozilla.kewis.ch/dav/omar.ics

Comment 8

10 years ago
(In reply to comment #7)
Trunk issue is already filed as Bug 387569.
Issues involves code from Mozilla 1.8 branch which is no longer used in Sunbird/Lightning 1.0pre (mozilla-1.9.1). -> INVALID
Status: NEW → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 117592
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.