"Sort Folder By Name" should have confirmation dialog

RESOLVED DUPLICATE of bug 209355

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 209355
14 years ago
14 years ago

People

(Reporter: Gabriel Seah, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040623
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040623

It is much too easy to accidentally sort a bookmark folder by name in the
Bookmark Manager, whether by pressing Ctrl + N while browsing your bookmarks, or
accidentally selecting the "Sort Folder By Name" command in the right click menu
(as I did).

A dialog box: "Are you sure you want to sort this folder by name?" should appear
so bookmarks, especially long and painstakingly sorted lists of them, do not get
screwed up.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Gabriel: Do you know, that tree structure is restored after Bookmark manager is
closed and opened again?
(Reporter)

Comment 2

14 years ago
I tried:

- Sorting by name, closing and then reopening Bookmark Manager. Tree structure
was not restored
- Sorting by name, pressing undo, closing and then reopening Bookmark Manager.
Again, tree structure was not restored

Comment 3

14 years ago
Known issue, see related Bug 209355. Perhaps both can be merged together?
(Reporter)

Comment 4

14 years ago
Please do, then, and rename 209355 so people like me searching for "Sort Folder
By Name" can find it.

Thank you

Comment 5

14 years ago
(In reply to comment #4)
> Please do, then, and rename 209355 so people like me searching for "Sort Folder
> By Name" can find it.

I can't do that. Not enough permissions. Ask in that bug to extend the
summary/bug report.
Product: Browser → Seamonkey

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 209355 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.