crash at shutdown (everytime) [@ ntdll.dll ] [@ - nsHashtable::Reset ]

VERIFIED DUPLICATE of bug 200119

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 200119
14 years ago
7 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
My mozilla crash when I shut it down. It crashes all the time. 100%.

TB196089X
TB196086K
TB196063H
TB193563M
(Reporter)

Comment 1

14 years ago
build 20040628 on WinXP

Updated

14 years ago
Keywords: talkbackid

Comment 2

14 years ago
TB193563M:
ntdll.dll + 0x131cd (0x7c9131cd)
ntdll.dll + 0x4702 (0x7c904702)
msvcrt.dll + 0x1c2de (0x77c2c2de)
??3@YAXPAX@Z
nsHashKey::`vector deleting destructor'
PL_DHashTableRawRemove 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/ds/pldhash.c,
line 591]
PL_DHashTableEnumerate 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/ds/pldhash.c,
line 623]
Severity: normal → critical
Summary: crash at shutdown (everytime) → crash at shutdown (everytime) [@ ntdll.dll ]

Comment 3

14 years ago
TB196063H looks same as TB193563M.

TB196086K (TB196089 looks same):
nsHashtable::Reset 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 353]
nsHashtable::Reset 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 338]
nsNSSComponent::StopCRLUpdateTimer 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/security/manager/ssl/src/nsNSSComponent.cpp,
line 889]
nsCOMPtr_base::assign_from_qi 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/glue/nsCOMPtr.cpp,
line 97]
nsObserverService::NotifyObservers 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsObserverService.cpp,
line 210]
nsProfile::ShutDownCurrentProfile 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/profile/src/nsProfile.cpp,
line 1365]
DoOnShutdown 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 809]
main 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1806]
WinMain 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1827]
WinMainCRTStartup()
kernel32.dll + 0x1774d (0x7c81774d)
Keywords: stackwanted, talkbackid
Summary: crash at shutdown (everytime) [@ ntdll.dll ] → crash at shutdown (everytime) [@ ntdll.dll ] [@ - nsHashtable::Reset ]

Comment 4

14 years ago
*** Bug 249878 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
I'm about 90% confident that this is a dup of 200119.

*** This bug has been marked as a duplicate of 200119 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

13 years ago
Status: RESOLVED → VERIFIED
Crash Signature: [@ ntdll.dll ] [@ - nsHashtable::Reset ]
You need to log in before you can comment on or make changes to this bug.