If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot reply to From: address if Reply-to: is set differently (mailing list)

RESOLVED DUPLICATE of bug 77304

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 77304
13 years ago
13 years ago

People

(Reporter: ethan fremen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040628 Firefox/0.9.1
Build Identifier: version 0.7.1 (20040626)

Mailing lists often set the Reply-to: to point at the list. There is no way, in
Thunderbird, to reply to the sender only if this option has been set

Reproducible: Always
Steps to Reproduce:
1. Receive an email from a (mailman) list that has the Reply-to header set.
2. Press Reply; reply is to List.
3. Press Reply All; reply is to List.



Expected Results:  
Reply-all should put the From: address and the Reply-to: address in the To: and
Cc: fields, respectively. This is only correct behaviour if the email is from a
list; you can tell if it is from a list by using the RFC2919 List-Id: header.

Comment 1

13 years ago
This is a dupe of 77304, which has been marked as INVALID.

However, I wish this feature would be added.  It is really very handy, and I've
know other email packages that have it.  PLEASE do not mark this defect as
invalid or dupe!

Comment 2

13 years ago
The work-around is extremely simple in Thunderbird 0.8: Click on the email
address link in the To field and choose the option «Compose mail to».

If you want to quote the original message: in the compose window, choose Options
> Quote Message from the menu or click on the Quote button.

If you want to attach the message: drag it from the message list window to the
compose window.

Comment 3

13 years ago
That isn't quite a full workaround, as the message won't thread correctly.
Replying would normally add "In-Reply-To:" and "References:" headers; composing
a brand new message will not.

In general of course, you *shouldn't* be ignoring "Reply-To:" headers, but given
the large number of lists which munge them, it would nevertheless be very useful. 

(We can shout for as long as we like about munging being bad, but until all the
commonly-used mail clients have a "Reply To List" function it will continue to
be a widespread practice. And since Mozilla still doesn't have this, we can't
really complain that others don't.)

Comment 4

13 years ago
I'm duping this to bug 77304 (as it should be), but I'm also about to reopen
that bug.

*** This bug has been marked as a duplicate of 77304 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.