Closed Bug 249575 Opened 15 years ago Closed 15 years ago

editusers.cgi has duplicate table endtag code

Categories

(Bugzilla :: Administration, task, trivial)

2.17
x86
Linux
task
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 238033

People

(Reporter: ulfjack, Assigned: justdave)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040403 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040403 Firefox/0.8

Line 195+196 are duplicate. This may mess up custom layouts (such as this:
http://bugzilla.conquer-space.net/). When the code is templatized, this bug
should become obsolete.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Which page of the editusers interface had this?
Version: unspecified → 2.17
Confirm bug for "Edit user" page.

As far as I can see, "EmitFormElements" is only called from the "Edit user" and
"Add user" pages.

The "Add user" page still has the bug, although I have removed one of the
closing tags:
Lines 195+196 of my current editusers.cgi:

        print "</TR></TABLE></TD>\n";
#    print "</TR></TABLE></TD>\n";

It seems to me that the print-line actually belongs inside the brackets. See
line 134:
if($user ne "") {
   print "</TR><TR><TH VALIGN=TOP ALIGN=RIGHT>Group Access:</TH><TD><TABLE><TR>";

That is where the subtable is opened.


(My change has fixed the 'Edit User'-Page, but the 'Add User'-Page is still broken.)

The change to templates was a really smart move ... if you ask me.
OK, someone else already got this.

This did provoke me to find another problem, though....  see bug 249862


*** This bug has been marked as a duplicate of 238033 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.