Closed Bug 249620 Opened 15 years ago Closed 11 years ago

inconsistent labeling: folder context menu for account node is named properties but goes to account settings

Categories

(Thunderbird :: Account Manager, defect, P4, trivial)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0a3

People

(Reporter: ivan.icin, Assigned: bisi)

Details

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Thunderbird version 0.7 (20040616)

When you right click account, there is option properties in context menu.
However, you find Account settings (not properties) in Tools menu

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
I still think that this is incosistent labeling
Version: unspecified → 1.5
I'd like to confirm this bug. It's inconsistent language use and it's still in the 1.5beta version. Imho, it can very well be relabeled to 'Account settings for Account' (where actually account should be replaced by the account name, but that would be a different bug, since that problem is also in the 'Get messages for Account')
Summary: incosistent labeling: account settings / properties → inconsistent labeling: account settings / properties
QA Contact: account-manager
CC'ing Bryan for this trivial UI issue.
Yes, similar text is also used for the account overview page.  The text should be more descriptive to where it will take you, lets change the "Properties..." text to "Account Settings..."
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-thunderbird3.0a2?
OS: Windows XP → All
Hardware: PC → All
Version: 1.5 → unspecified
Attached patch patch v0.1 (obsolete) — Splinter Review
Taking bug...

An initial attempt at correcting this. Should I also change the code in the mailnews/ directories? (I only changed the code in the mail/ directory)
Assignee: mscott → nth10sd
Status: NEW → ASSIGNED
Attachment #318544 - Flags: review?(mkmelin+mozilla)
(In reply to comment #6)
> An initial attempt at correcting this. Should I also change the code in the
> mailnews/ directories? (I only changed the code in the mail/ directory)

To add more details to my question, there are also other files in suite/ and mailnews/ that call the menuitem ids along with other things, that might regress in SM in this fix for TB.

(Did a quick mxr search and found several similar files touched in the patch also in mailnews/, but the patch doesn't address the changes for mailnews/)
That depends on if you want to fix it for thunderbird or both tb&sm. In this case the similar files outside mail/ are for seamonkey - the patch as is doesn't affect/regress them.
Comment on attachment 318544 [details] [diff] [review]
patch v0.1

This makes the context menu for a normal folder show "Account Settings" too, not only the account node.

Do we need the "Account", or is simply "Settings..." better? It's an context menu after all.

(On a side note, it's easiest to apply patches if you stand in the mozilla dir when doing the cvs diff.)
Attachment #318544 - Flags: review?(mkmelin+mozilla) → review-
(In reply to comment #9)
> Do we need the "Account", or is simply "Settings..." better? It's an context
> menu after all.
I thought that one word is OK when submitting bug (just wasn't sure whether settings or properties)
I would think "Settings" would suffice unless Bryan thinks otherwise.

Should the menuitem ids be changed as well? philor has pointed out that this may trivially break things probably for extensions.

Patch pending these two issues.
You're probably best off making another menu item for it, hiding/showing that and the Properties item as appropriate, and so on... 
Gary: Agreed, I think Settings will work.
And I agree with Magnus that changing folder Properties is the wrong thing to do :)
phil and i are in constant agreement :)
Attached patch patch v0.2 (obsolete) — Splinter Review
So I'm not changing anything else but the word "Properties..." to "Settings..."

Is there anything else I missed, since the rest of the changes in the first patch seem unneeded?
Attachment #318544 - Attachment is obsolete: true
Attachment #322068 - Flags: review?(mkmelin+mozilla)
Comment on attachment 322068 [details] [diff] [review]
patch v0.2

You are still changing the folder properties to read "Settings...". You should only change it for the account node.

So, create another menu item, and enable&show it when we have an account node, hiding the "Properties" for account nodes, showing it for normal folders.
Attachment #322068 - Flags: review?(mkmelin+mozilla) → review-
wanted‑thunderbird3+
Flags: wanted-thunderbird3.0a2? → wanted-thunderbird3+
Summary: inconsistent labeling: account settings / properties → inconsistent labeling: folder context menu for account node is named properties but goes to account settings
Deassigning myself as I don't forsee myself having the time to work on this bug in the next few weeks / months.
Assignee: nth10sd → nobody
Status: ASSIGNED → NEW
Leaving as wanted3+, target milestone milestone beta1. Any takers?
Keywords: helpwanted
Priority: -- → P4
Target Milestone: --- → Thunderbird 3.0b1
Whiteboard: [needs new patch]
Attachment #322068 - Attachment is obsolete: true
The wanted3+ bug list is really useful for contributors. :)
Assignee: nobody → bisi
Attached patch patch v1 (obsolete) — Splinter Review
This patch also includes the SeaMonkey bits. I'll ask for a separate SeaMonkey review/approval later (if needed).
Attachment #335677 - Flags: review?(mkmelin+mozilla)
Comment on attachment 335677 [details] [diff] [review]
patch v1

Just two nits: trailing spaces here
>+  
>+  if (!isServer)

... and after this

>+    EnableMenuItem("folderPaneContext-settings", true);
>+  }

r=mkmelin for the /mail bits with that fixed
Attachment #335677 - Flags: review?(mkmelin+mozilla) → review+
Keywords: helpwanted
Whiteboard: [needs new patch] → [just nits to fix left]
Karsten, do you want this patch in SeaMonkey?
Attachment #335677 - Attachment is obsolete: true
Attachment #335782 - Flags: review?(mnyromyr)
Attachment #335782 - Flags: review?(mnyromyr) → review+
Comment on attachment 335782 [details] [diff] [review]
patch v1 with nits fixed

Yes, many thanks!
Keywords: checkin-needed
Whiteboard: [just nits to fix left]
Patch checked in, changeset id: 230:0b8451c8483d. I'm assuming this is fixed now.
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
No longer blocks: TB2SM
Yes, this bug is fixed now. Thanks for the checkin!
You need to log in before you can comment on or make changes to this bug.