Focus outlines for checkboxes and radios should surround <label>

VERIFIED DUPLICATE of bug 142898

Status

()

Core
Keyboard: Navigation
VERIFIED DUPLICATE of bug 142898
14 years ago
4 years ago

People

(Reporter: Aaron Leventhal, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug, {access})

Trunk
x86
All
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
Steps:
1. Load a page with radio buttons or checkboxes that use <label> to associate a
text label with each.
2. Click on a radio button or checkbox, or navigate to it with the keyboard

What happens:
The focus outline is around the actual radio button or checkbox

Expected:
The focus outline is around the label. IE gets it right.
Created attachment 152314 [details]
simple test case
(Assignee)

Comment 2

14 years ago
Neo, will you take this bug?

BTW, usually the radio button or checkbox comes before the label, but your
testcase is okay since it should work either way.

Comment 3

14 years ago
Technically you should be able to enclose the button and text in the same label
but IE doesn't like that...
(Assignee)

Comment 4

14 years ago
(In reply to comment #3)
> Technically you should be able to enclose the button and text in the same label
> but IE doesn't like that...

Do you mean enclose them in the same focus outline?

Comment 5

14 years ago
This is a dup of bug 142898.
(Assignee)

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 142898 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.