Conversion of boolean conditions in SQL statements for better db independence (take 2)

RESOLVED FIXED in Bugzilla 2.20

Status

()

RESOLVED FIXED
15 years ago
6 years ago

People

(Reporter: dkl, Assigned: dkl)

Tracking

2.17.7
Bugzilla 2.20
Bug Flags:
approval +
approval2.18 -

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
One more spot was discovered by Tomas Kopal where a boolean condition needs to
be sanitized for better db independence. Patch forthcoming.

Updated

15 years ago
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 1

15 years ago
Assignee: justdave → dkl
Status: NEW → ASSIGNED
(Assignee)

Comment 2

15 years ago
Seeking approval for checkin.
Flags: approval2.18+

Comment 3

15 years ago
getting a bit ahead of ourselves :-)
Flags: approval2.18+ → approval2.18?

Updated

15 years ago
Flags: approval2.18?

Updated

15 years ago
Attachment #152701 - Flags: review?(bugreport)
(Assignee)

Comment 4

15 years ago
Ack, you're right. I meant review? but got the two mixed up, and then to top it
off hit the + instead of ?. 

/me heads out for more coffee ;)

Updated

15 years ago
Attachment #152701 - Flags: review?(bugreport) → review+

Updated

15 years ago
Flags: approval?
Flags: approval2.18?

Comment 5

15 years ago
dkl: I'm assuming that there are a whole bunch of pgsql changes that will need
to go in that won't be on 2.18.  Wouldn't it be better to target this for (very
early) 2.19??
(Assignee)

Comment 6

15 years ago
I would think this one would be ok to get into 2.18 since it is not PgSQL
specific really. Plus this is part of my trying to break the huge PgSQL patch
down into smaller generic pieces for easier review. But I am up for whatever
others think.
ehhh...  I don't want to mess with this this close to branch point.  Let's check
it in on the trunk after we branch (that's happening later tonight).

2.18 isn't going to have multi-DB support anyway, so there's no reason it has to
be there.
Flags: approval2.18? → approval2.18-
Target Milestone: --- → Bugzilla 2.20

Comment 8

15 years ago
*** Bug 250832 has been marked as a duplicate of this bug. ***
Flags: approval? → approval+
(Assignee)

Comment 9

15 years ago
Just as a refresher, the approval that justdave granted means it is ok to check
this in against HEAD since 2.18 is not on it's own branch?

Tnanks

Updated

15 years ago
Blocks: 98304

Comment 10

15 years ago
What is this one still waiting for? ;-)

Comment 11

15 years ago
David: it's ok for you to check this in on the tip (on the HEAD).

You don't need to worry about branches (2_16, 2_18 etc).
(Assignee)

Comment 12

15 years ago
Thanks, will get it in. 

Comment 13

15 years ago
Another month gone, another whine :-). What is this waiting for now? :-)

Comment 14

15 years ago
Checking in request.cgi;
/cvsroot/mozilla/webtools/bugzilla/request.cgi,v  <--  request.cgi
new revision: 1.15; previous revision: 1.14
done
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.