After creating a series DEFAULT query format is to create a series

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Reporting/Charting
P1
blocker
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: Joel Peshkin, Assigned: glob)

Tracking

({regression})

2.17.7
Bugzilla 2.18
regression
Bug Flags:
approval +
approval2.18 +
blocking2.18 +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
After the preferred format cookie went in, the search page uses the format of
the last search page used... even if it was for a series.
(Reporter)

Updated

14 years ago
Priority: -- → P1
Target Milestone: --- → Bugzilla 2.18
(Reporter)

Comment 1

14 years ago
This is a regression from bug 245077.

Critical because search is rendered unusable unless you manually clear the cookie.
(Reporter)

Updated

14 years ago
Flags: blocking2.18?
I'd even call it a blocker.

I specifically rejected the first patch for the query page for exactly this
reason...
Severity: critical → blocker
Flags: blocking2.18? → blocking2.18+
Assignee: gerv → bugzilla
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

14 years ago
Created attachment 152896 [details] [diff] [review]
use whitelist instead of blacklist for format cookie
(Assignee)

Updated

14 years ago
Attachment #152896 - Flags: review?(justdave)
Comment on attachment 152896 [details] [diff] [review]
use whitelist instead of blacklist for format cookie

>+# Set cookie to current format as default, but only if the format
>+# one that we should remember.
>+my $format_qm = quotemeta($vars->{'format'});
>+if (grep /^$format_qm$/, qw(specific advanced)) {

variables in regexps are naughty. ;)

how about:

if (grep {$_ eq $vars->{'format'}} qw(specific advanced)) {

Then you don't need to mess with quotemeta or anything.
Attachment #152896 - Flags: review?(justdave) → review-
(Assignee)

Comment 5

14 years ago
Created attachment 152899 [details] [diff] [review]
changed grep to follow dave's suggestion
Attachment #152896 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #152899 - Flags: review?(justdave)
Attachment #152899 - Flags: review?(justdave) → review+
Flags: approval2.18+
Flags: approval+
(Reporter)

Comment 6

14 years ago
checked in on both branches
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

14 years ago
*** Bug 251157 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.