Switching to tab doesn't show its blocked pop-up information bar.

VERIFIED DUPLICATE of bug 255162

Status

()

VERIFIED DUPLICATE of bug 255162
14 years ago
14 years ago

People

(Reporter: jhawkins002, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+

If you open a link that results in a pop-up bearing page opening in a background
tab, the new popup notification does not display. 

Also, if you are on a page that does show the new notification, and you switch
to another tab, the notification is lost.


**NOTE: I include these both in the same bug, because I am pretty sure they are
the same problem -- there is just more than one way to make it happen...

Reproducible: Always
Steps to Reproduce:
1. Go to cnn.com
2. Open a link in a tab
3. The new pop-up notification does not display anywhere

Also...

1. Make sure you have an extra tab or two open in the background
2. Go to cnn.com in one of them
3. Marvel at the new notification at the top
4. Switch to another tab, then come back to the one with CNN
5. The notification has gone *poof*!


Actual Results:  
Notification dissappears, or never appears at all - although the statusbar icon
does report a blocked popup

Expected Results:  
Notification should display, and stay with the tab in which the pop-up was called.

Updated

14 years ago
Summary: New popup control notification at top of browser fails to display if page loaded in a tab. → New popup control notification at top of browser fails to display if page loaded in a tab.

Comment 1

14 years ago
Confirming. The info bar when XPIs are blocked from loading DOES rerender, if
you switch to another tab and come back. (However, if you click Options, then
cancel that dialog, the XPI info bar disapears... not sure if this is good, or
bad UI.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Summary: New popup control notification at top of browser fails to display if page loaded in a tab. → Switching to tab doesn't show its blocked pop-up information bar.

Comment 2

14 years ago
Blake filed a new bug and fixed this. Duping.

*** This bug has been marked as a duplicate of 255162 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.