F1 on Win/*nix should bring up Help Contents

VERIFIED FIXED

Status

SeaMonkey
Help Viewer
P3
normal
VERIFIED FIXED
14 years ago
2 years ago

People

(Reporter: Steffen Wilberg, Assigned: Steffen Wilberg)

Tracking

({fixed-aviary1.0})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
Every single windows app uses F1 to bring up Help.
The respective SeaMonkey bug is bug 88739.

Keys to use are VK_F1 and VK_HELP. The latter only works on Mac:
http://lxr.mozilla.org/aviarybranch/search?string=VK_HELP
(Assignee)

Comment 1

14 years ago
Taking.

I don't have a Mac, so I hope this is a recent Mac keyboard:
http://www.internet4classrooms.com/mackeyboard.htm
This means that the help key should work without key modifiers.
Assignee: rlk → steffen.wilberg
(Assignee)

Comment 2

14 years ago
Created attachment 153033 [details] [diff] [review]
patch [checked in: comment 6]

Help key for Mac, F1 for other platforms.
(Assignee)

Updated

14 years ago
Attachment #153033 - Flags: review?(rlk)
(Assignee)

Updated

14 years ago
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0?

Updated

14 years ago
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0RC1+
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0+
Priority: -- → P3
Comment on attachment 153033 [details] [diff] [review]
patch [checked in: comment 6]

>@@ -58,9 +69,6 @@
>             position="1"
>             accesskey="&helpContents.accesskey;"
>             key="key_openHelp"
>-# Use the Thunderbird content pack if we're building thunderbird. Otherwise use the Firefox content
>-# pack. We should use else instead of elseif to prevent build errors if MOZ_PHOENIX and MOZ_THUNDERBIRD
>-# are not built.

why remove this comment? its still valid here too.

r=me with that comment restored.
Attachment #153033 - Flags: review?(rlk) → review+

Comment 4

14 years ago
Actually, I think the correct help key is cmd+? on mac, see bug 88739, comment #71 .
(Assignee)

Comment 5

14 years ago
We're going to try VK_HELP. There's no harm done if it doesn't work, as long as
it doesn't break the menu or displays weird characters.

Again, I don't have a Mac, but the link from comment 1 says for the Help key:
"Help - Brings up the Help index for the application you are working in. If you
are in the Finder this brings up Mac OS help."

I'm not sure about Cmd+?. The above mentioned document says: "Cmd+? to launch
the help menu in the Finder". CCing Aaron.
(Assignee)

Comment 6

14 years ago
Checked in br & trunk 2004-07-19 07:14-07:15 (with the comment restored).
-> fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.0beta
(Assignee)

Comment 7

14 years ago
Tracy, can you test if the Help key on a Mac brings up Help Contents, like F1
does on Windows and *nix, please?
Builds 07/19 and newer.

Comment 8

14 years ago
Help key (or cmd+?) does not open Help on Mac OSX with FF0.9+ build
2004-07-19-10-0.9

Comment 5 noted concern about possible menu breakage.  With this build the menu
looks fine.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

14 years ago
Steffen, there seem to be a mozdev bug dealing with the same problem:
http://bugzilla.mozdev.org/show_bug.cgi?id=5409 It was fixed in June. But it
doesn't looks like this has been checked in to the FF trunk yet.
(Assignee)

Comment 10

14 years ago
Stefan, that must have been the code I replaced. VK_HELP was used before, but
that only exists on Mac, and seems to be broken there when looking at comment 8.
Land it now. DTD changes aren't likely to get easy approval after RC1. 
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
(Assignee)

Updated

14 years ago
Depends on: 124393
(Assignee)

Comment 12

14 years ago
So VK_HELP doesn't work at all. I tried to use Cmd+? but I can't get that to
work either with |key="?" modifiers="control"|. It displays Ctrl+? in the menu,
but it doesn't bring up Help Contents.

Comment 13

14 years ago
(In reply to comment #12)
> So VK_HELP doesn't work at all. I tried to use Cmd+? but I can't get that to
> work either with |key="?" modifiers="control"|. It displays Ctrl+? in the menu,
> but it doesn't bring up Help Contents.

No, VK_HELP doesn't work at all. Maybe the real solution is making VK_HELP work.
From what it looks like to me, it was first created somewhere in bug 88739.

The bug stefan_h noted does checkin the code you posted, so it does not work on
the Mac.
(Assignee)

Updated

14 years ago
Attachment #153033 - Attachment description: patch → patch [checked in: comment 6]

Comment 14

14 years ago
This might have caused bug 252750, "space goes to help window" (Mac OS X).
could the changes here have caused bug 253603? in that bug, even the menu item
fails to bring up Help Contents (linux and windows trunk).
(Assignee)

Comment 16

14 years ago
Bug 252750 will remove the VK_HELP keybinding on Mac for now.
I filed bug 253693 for (re)introducing either VK_HELP or Cmd+? on Mac once the
problems with these are sorted out.

Reducing this bug to Windows/Linux, which is fixed already, see comment 6.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
No longer depends on: 124393
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
Summary: F1 on Win/*nix, Help key on Mac doesn't bring up Help → F1 on Win/*nix should bring up Help Contents
(Assignee)

Updated

13 years ago
No longer blocks: 250631

Updated

13 years ago
Component: Help Viewer → Help Viewer
Flags: review+
Flags: blocking-aviary1.0PR+
Flags: blocking-aviary1.0-
Product: Firefox → Toolkit
Target Milestone: Firefox1.0beta → ---
Status: RESOLVED → VERIFIED
Product: Toolkit → Seamonkey
You need to log in before you can comment on or make changes to this bug.