Closed Bug 251189 Opened 19 years ago Closed 19 years ago

Ctrl-/shift-/middle-/secondary-click on entry in back/foward-button history doesn't exhbit expected behaviour

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 246719

People

(Reporter: blakesley, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

[I am not sure whether the foward and back buttons are under the history, menus
or general component.  Could this be clarified?]

One cannot automatically open a page in the back/forward-button history in a new
window or new tab (using shift-click, ctrl-click or middle-click) and one cannot
perform this and other functionality (e.g.: copy link location) from a context
menu (using secondary-click).



Reproducible: Always
Steps to Reproduce:
1. Click the arrow beside either the back or the forward button on the
navigation bar (or click the back or forward button with your pointing device's
secondary button) when the button has a history (i.e.: is not greyed out).

2. Do one of the following:
   (a) Click on an entry in the resulting menu with your pointing device's
secondary button.
   (b) Click on an entry in the resulting menu with your pointing device's
middle button.
   (c) Click on an entry in the resulting menu with your pointing device's
primary button while holding down "Ctrl" on your keyboard.
   (d) Click on an entry in the resulting menu with your pointing device's
primary button while holding down "Shift" on your keyboard.
Actual Results:  
   (a) Nothing.
   (b) Nothing.
   (c) Opens page in current window and tab-pane (as if "Ctrl" was not held down).
   (d) Opens page in current window and tab-pane (as if "Shift" was not held down).

Expected Results:  
   (a) Display a context menu similar to the one displayed when clicking on an
entry in the history sidebar (see ASCIIart below).
+---------------------+
|_O_pen               |
|Open in New _W_indow |
|Open in New _T_ab    |
+---------------------+
|_B_ookmark this Link |
|_C_opy Link Location |
+---------------------+
   (b) & (c) Open the selected page in the back/forward-button history in an new
tab-pane.
   (d) Open the selected page in the back/forward-button history in an new window.
Item a) was WONTFIXed in Bug 248669
Items b), c) & d) all work as you requested in the latest nightlies (see Bug
246719).

*** This bug has been marked as a duplicate of 246719 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.