If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

'Enter' key doesn't work properly in multi-line mode

RESOLVED DUPLICATE of bug 252589

Status

()

Core
XUL
--
major
RESOLVED DUPLICATE of bug 252589
13 years ago
9 years ago

People

(Reporter: Dmitry, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040712
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040712

In Chatzilla 0.9.64e [Mozilla rv:1.8a2/20040712] 'Enter' key doesn't put a new
line. When pressed, some invisible symbol is inserted in the same line. This
symbol can be deleted by 'backspace'.

Reproducible: Always
Steps to Reproduce:
1. Press 'ctrl-up'
2. Press 'enter'
3. Press 'backspce'

Actual Results:  
Invisible symbol inserted after step 2, then deleted at step 3.

Expected Results:  
A newline created, when deleted.

M.b. this has some connection with Bug 228962.

Comment 1

13 years ago
This is some bug in the Mozilla toolkit. I'll be damned if I know what, but the
multiline box recently has been not showing newlines properly.
Assignee: rginda → nobody
Component: ChatZilla → XP Toolkit/Widgets: XUL
QA Contact: samuel

Comment 2

13 years ago
I believe this is the same issue as bug 252589, and they have a patch! We'll see. :)

*** This bug has been marked as a duplicate of 252589 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.