Closed Bug 251396 Opened 16 years ago Closed 10 years ago

print dialog blocks compose window (or partly blocks it, if a cached window)

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sspitzer, Unassigned)

Details

print dialog blocks compose window, reply quoting

try this:

1)  select a message in the 3 pane, bring up the print dialog, but don't dismiss it.
2)  hit the reply button, and if the cached compose window is available, it will
come up in a partial state (it will not fill in subject or quote the message, etc)
3)  dismiss the print dialog and the cached compose window will finish setting up.

if you do this and there is no cached compose window to use, it will block the
creation of the compose window.

I haven't tried from the stand alone msg window yet.

I'm pretty sure the monkey will have this bug too, so cc neil.
It looks as if printing does some sort of weird modal call on the 3 pane window
even though it's not its parent. Since it really is modal in the browser,
perhaps we can work around it by making it modal in the 3 pane window too.
No, that didn't help... it still blocks other windows for some reason.
xref bug 144601 -- I think this is a shared, backend problem.
Actually even the File/Open dialog blocks the compose window, so I suspect this
is a core Windows event handling issue - I guess the native modal dialogs are
conflicting with Mozilla's custom event processing.
QA Contact: front-end
Assignee: mscott → nobody
I can't reproduce results of step 2 nor step 3.
=> WFM

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.4) Gecko/20100521 Lanikai/3.1.1pre
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Might well have been fixed by the threadmanager changes.
You need to log in before you can comment on or make changes to this bug.