message display order changes when clicking on "Click to display Message thread" header

RESOLVED DUPLICATE of bug 219787

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 219787
14 years ago
13 years ago

People

(Reporter: Thomas Wolf, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

I always display msgs in reverse-chronological order (ie. youngest email first)
by clicking on the "Date" header to have arrow point up.  Sometimes I want to
read a complete thread and I click on the "Click to display Message thread"
column header.  But when I do that, all the messages (within and outside the
threads) become sorted chronologically.  If I click a second time, it
re-establishes the reverse-chronological date ordering outside the threads and
chronological ordering within the thread - which is what I expect.  The default
should be the latter, not the former!  For the longest time, I didn't even know
that I could click on that icon multiple times - since it doesn't have any
"direction" indicator like other columns (e.g. the arrow on "Date".)

Reproducible: Always
Steps to Reproduce:
1. Bring up mail click on "Date" in msg window until reverse date order appears.
2. Click on "Click to display Message thread" column header

Actual Results:  
All messages, including thread members, are chronologically ordered.

Expected Results:  
Maintain the reverse-chronological ordering previously specified or _at least_
provide visual feedback that this header can change ordering!

Comment 1

13 years ago
I'm finding the description of the undesirable behavior hard to understand.

I'm *guessing* that what is meant is:  when the Thread column header is clicked, 
the Sort Ordering is changed from Descending to Ascending.  Yes, it does this; 
however, you can change the behavior.  Bug 219787 implemented a tweak such that, 
if you set a preference, clicking the thread column header doesn't affect the 
sort criterion or ordering; and bug 234690 implemented a UI for that preference.

If this is what you meant, please mark this bug as a dupe of 219787.

Comment 2

13 years ago
Bug also occurs on Mozilla Thunderbird/Fedora Core 3.  All other details the same.

Comment 3

13 years ago
No response from reporter; duping.

*** This bug has been marked as a duplicate of 219787 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.