Find as you type no longer works on View Source page

RESOLVED DUPLICATE of bug 250279

Status

()

Toolkit
View Source
RESOLVED DUPLICATE of bug 250279
14 years ago
10 years ago

People

(Reporter: Thomas Rutter, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+

Find as you type (pressing slash and then typing) used to work in the "View
Source" page.  This no longer works.

In order to search in the View Source page, one must not press Ctrl+F and open
the dialog box.

This is inconsistent with the browser window, where Find as you Type still works.

Reproducible: Always
Steps to Reproduce:
1. View the source code of this page
2. Press slash (/) followed by some word on the page

Actual Results:  
Nothing happened

Expected Results:  
Done a "Find as you type"

Similar to Bug #250279 (View Source doesn't use Find Toolbar) but this relates
to behaviour specifically of Find as you Type, rather than the appearance of the
dialog.
sp3k (linux) and I (winXP) confirmed on IRC that typeahead find and regular find
in page are currently broken.

Severity: normal → major
Status: UNCONFIRMED → NEW
Component: View Source → General
Ever confirmed: true
Flags: blocking-aviary1.0RC1?
OS: Windows XP → All
Hardware: PC → All
Summary: Find as you type no longer works on View Source page → Find no longer works
Version: unspecified → 1.0 Branch
Duping to 251543.

*** This bug has been marked as a duplicate of 251543 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

14 years ago
Not duplicate; this bug refers to "View Source" page.
Component: General → View Source
Summary: Find no longer works → Find as you type no longer works on View Source page

Comment 4

14 years ago
Now, In FindToolbar, it has FAYT option.
If it has FindToolbar by "View Page Source", I will think that FAYT can be used
similarly.

duplicate 250279 ?
(Reporter)

Comment 5

14 years ago
> duplicate 250279 ?

If 250297 is resolved by adding the find toolbar to View Source, then this bug
will be no longer.  If however it's resolved some other way, such as deciding
that View Source doesn't need a find toolbar, then this bug may remain.  In my
opinion it's not strictly a duplicate, depending on what happens with 250297. 
In the meantime FAYT on View Source is not doing anything at all - find toolbar
or not.

Comment 6

14 years ago
Too many if:s for keeping this bug open. Duping, please reopen this bug if FAYT
still doesnt work after bug 250279 has been fixed.

*** This bug has been marked as a duplicate of 250279 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

14 years ago
I do not believe that this is a duplicate of bug #250279.

This bug refers to "Find As You Type" - that is, the action of pressing slash
and then typing a word in order to find it - NOT the Find Toolbar and not the
appearance of the window.  Whether it uses the Find Toolbar or not is not
related to this bug.

This bug is similar to bug #250279 only so far as if the Find Toolbar is added
to the View Source page, as bug #250279 calls for, then this bug would no longer
be relevant.  This has not happened and there is no guarantee it would happen,
and therefore this bug remains relevant.  This kind of relationship between two
bugs is common and is not grounds for resolving one as a duplicate of the other.
 This would be a duplicate of another bug only if it described the same
behaviour as another.

The bug reporting guidelines state that one should not mention multiple problems
in one bug report - one should keep each problem separate.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

14 years ago
Severity: major → normal

Comment 8

14 years ago
Thomas, I appreciate your adhering so closely to the bug filing guidelines, and
you are generally correct. However, in this case, because the find toolbar and
FAYT are now inextricably intertwined, I'm going to dup these two bugs, because
they'd be fixed by the same patch and we need our 1.0 blocker list to be an
accurate representation of how many fixes are needed.

*** This bug has been marked as a duplicate of 250279 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Removing blocking?
Flags: blocking-aviary1.0PR?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.