View Source doesn't use Find Toolbar / Since Find Toolbar was implemented, Find as you type is broken in "Page Source" window

VERIFIED FIXED in mozilla1.7.5

Status

()

Toolkit
Find Toolbar
P3
normal
VERIFIED FIXED
13 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Assigned: Blake Ross)

Tracking

(4 keywords)

unspecified
mozilla1.7.5
access, fixed-aviary1.0, late-l10n, regression
Points:
---
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

80.37 KB, patch
Brian Ryner (not reading)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
 

Updated

13 years ago
Flags: blocking-aviary1.0RC1?
-> Find Toolbar component.
Component: View Source → Find Toolbar / FastFind

Comment 2

13 years ago
*** Bug 251660 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

13 years ago
*** Bug 251660 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0RC1-
Flags: blocking-aviary1.0+
Priority: -- → P4
*** Bug 253272 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
If/when fixed, would this also cover FAYT in help? Not sure if it's supposed to
work there or not, but I don't see a reason why it shouldn't.
(In reply to comment #5)
> If/when fixed, would this also cover FAYT in help? Not sure if it's supposed to
> work there or not, but I don't see a reason why it shouldn't.

That's bug 253621, which I just filed.  Thanks for reminding us about it!
Assignee: bugs → firefox
Severity: minor → normal
Keywords: access, regression
Priority: P4 → P3
...and the find toolbar also broke FAYT in any other gecko window (e.g.
Chatzilla, Help system, etc.)...
OS: Windows XP → All
Hardware: PC → All
Summary: View Source doesn't use Find Toolbar → View Source doesn't use Find Toolbar / Since Find Toolbar was implemented, Find as you type is broken in "Page Source" window
Why did we lose FAYT in other windows?  We should restore compatibility.

/be

Comment 9

13 years ago
*** Bug 262914 has been marked as a duplicate of this bug. ***
Blocks: 253621

Comment 10

13 years ago
*** Bug 263622 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Whiteboard: ETA 10/17
Whiteboard: ETA 10/17 → ETA 10/15

Comment 11

13 years ago
I really don't think FAYT in view source should be something that we'd hold the
release for. Normal ctrl+f find dialog find works just fine in view source and
that's good enough. We really should minus this bug. 
Is there anything to gain by removing the old find dialog for 1.0?

/be
(Assignee)

Comment 13

13 years ago
Created attachment 162267 [details] [diff] [review]
patch
Attachment #162267 - Flags: review+
(Assignee)

Comment 14

13 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Keywords: fixed-aviary1.0
The net effect of this checkin, after most of the l10n changes were reverted,
was to change

-<!ENTITY useTypeAheadFind.label       "Use Find As You Type">
+<!ENTITY useTypeAheadFind.label       "Begin finding when you begin typing">

I'm going to post-approve this change, since it doesn't break the existing
localizations we're trying to put out for RC, but grrr.
Keywords: late-l10n
As the l10n change is approved, please make sure to fix the label in Help
documentation:

http://lxr.mozilla.org/aviarybranch/source/browser/components/help/locale/en-US/prefs.xhtml#419

It'd be nice if you'd fix this issue on both branch *and* trunk, but if you
don't, just let me know here or via email and I'll fix it on trunk.

Comment 17

13 years ago
FYI, I attached a patch to Bug #264852 that trys to fix the thunderbird
regressions this patch introduced into thunderbird's view source dialog on the
branch.

Comment 18

13 years ago
v.
Status: RESOLVED → VERIFIED
Whiteboard: ETA 10/15
Target Milestone: --- → Firefox1.0

Comment 19

13 years ago
*** Bug 265963 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.