Browser hang on Go Back after viewing pdf(Adobe Acrobat 6.0)

RESOLVED DUPLICATE of bug 214137

Status

()

--
critical
RESOLVED DUPLICATE of bug 214137
15 years ago
13 years ago

People

(Reporter: boofy_bloke, Unassigned)

Tracking

({hang})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040716
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040716

I go to the page, read the pdf. ALT+LEFT ARROW acts like a Page Up in the pdf
but doesn't affect the browser. I click on the back button and Mozilla hangs. I
have to CAD to close it.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

15 years ago
Severity: major → critical
Keywords: hang
hang != crash (adjusting summary)
Summary: Browser crashes on Go Back after viewing pdf → Browser hang on Go Back after viewing pdf

Comment 2

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040721
Firefox/0.9.1+

I'm seeing this too (on my work machine).  Going back or clicking a link in the
PDF causes Firefox to hang.

Sometimes it also makes a dialog appear.  It says something like "You have one
or more PDFs open.  Are you sure you want to exit Acrobat reader?"  Clicking the
"Exit" button in that dialog sometimes makes Firefox stop hanging.

Comment 3

15 years ago
*** Bug 253128 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
Confirming based on duplicate and comment #2
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
URGENT but nothing new to Firefox 1.0alpha! Running Adobe Acrobat Reader or
Acrobat 6.0 full-blown, under W 2K, I get the SAME response I have had under
previous versions of Firefox/Phonix/FireBird/that browser thing and Adobe 5.n
and 6. Once you open an adobe document in the browser, you cannot close Adobe,
nor can you open a new tab, go anywhere, go back, do anything else without
shutting down the browser (sometimes with Taskmanager, and getting an Adobe
warning message.

DO SOMETHING ABOUT THIS ONE, FAST - IT'S GOT COBWEBS ON IT ALREADY - suggestion
- divert all PDFs to their own new tab

Comment 6

15 years ago
URGENT but nothing new to Firefox 1.0alpha! Running Adobe Acrobat Reader or
Acrobat 6.0 full-blown, under W 2K, I get the SAME response I have had under
previous versions of Firefox/Phonix/FireBird/that browser thing and Adobe 5.n
and 6. Once you open an adobe document in the browser, you cannot close Adobe,
nor can you open a new tab, go anywhere, go back, do anything else without
shutting down the browser (sometimes with Taskmanager, and getting an Adobe
warning message.

DO SOMETHING ABOUT THIS ONE, FAST - IT'S GOT COBWEBS ON IT ALREADY - suggestion
- divert all PDFs to their own new tab
Product: Browser → Seamonkey

Comment 7

14 years ago
I have to agree.  Once you hit the "go back" button, all the thing does is
recycle, and it locks **all** sessions of the browser and the newsreader.  The
only remedy I've found so far is to go through task manager to kill all
sessions, and sometimes it takes three or four tries to do that.  I'm running XP
home edition.

If the PDF opened in its own window, we might be able to close just that one
window.  I haven't tried that yet, but it *might* be worth trying.

Comment 8

14 years ago
I found a solution that works for me.  If you go to your adobe reader and select
/edit  /preferences  /internet and uncheck the box "Display PDF in Browser", it
is possible to close the pdf file and return to the browser.  I have implemented
this on two computers and it has solved the problem.

Comment 9

14 years ago
(In reply to comment #8)

That's not a solution, it's a workaround.  (it solves a bug in a feature by
eliminating the feature - like curing the disease by killing the patient) 
Workarounds are okay but this issue does need a real solution.

> I found a solution that works for me.  If you go to your adobe reader and select
> /edit  /preferences  /internet and uncheck the box "Display PDF in Browser", it
> is possible to close the pdf file and return to the browser.  I have implemented
> this on two computers and it has solved the problem.

Comment 10

14 years ago
Well, workaround or not, it *does* seem to work.  Thanks for the tip.

It could be worse, after all.... they could decide this bug *is* a feature....

:)

Comment 11

14 years ago
(In reply to comment #10)
Yeah it's hanging for your own good, to preserve your system's integrity. :D

Comment 12

13 years ago
(In reply to comment #10)
It does NOT work for me. In my case, if I wait about 3 minutes, I get the Exit box. However, If I first activate Adobe Reader (Ver. 6) and leave it active, THEN use the browser (Ver 1.5), it works perfectly.

> Well, workaround or not, it *does* seem to work.  Thanks for the tip.
> 
> It could be worse, after all.... they could decide this bug *is* a feature....
> 
> :)

Comment 13

13 years ago
==> plugins
Assignee: general → nobody
Component: General → Plug-ins
Product: Mozilla Application Suite → Core
QA Contact: general → plugins
DUP of Bug 214137? (already WORKSFORME since resolved by 6.0.1)
Summary: Browser hang on Go Back after viewing pdf → Browser hang on Go Back after viewing pdf(Adobe Acrobat 6.0)

Comment 15

13 years ago

*** This bug has been marked as a duplicate of 214137 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
No longer blocks: 336184
You need to log in before you can comment on or make changes to this bug.