Closed Bug 214137 Opened 17 years ago Closed 16 years ago

Unload of Acrobat 6.0(.0) hangs browser (note:resolved by 6.0.1)

Categories

(Core :: Plug-ins, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gigalo, Assigned: peterlubczynski-bugs)

References

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I am currently using Firbird 0.6 and Adobe Acrobat 6.0.0.19/05/2003.  When
attempting to unload Acrobat, after loading a pdf into a seperate tab, the
browser hangs.  I have noticed that the browser appears to hang only when
closing the final tab that contains an Acrobat document.  The bug does not
appear if a seperate copy of Acrobat is running at the time that the final pdf
tab is closed.

I have not tested this with only the reader installed.

Reproducible: Always

Steps to Reproduce:
1.  With Adobe Acrobat 6.0 retail installed, open up
http://www.klondikedays.com/press_release.html and open one of the relases up
into a seperate tab.

2.  Switch to that tab and close it.

Actual Results:  
Broser hangs indefinetly

Expected Results:  
Dismiss the tab and close the instance of Acrobat.
maybe dupe of bug 204550.
Component: Browser-General → Plug-ins
Keywords: hang
Looks very similar to bug 212067, but that bug talks about a crash.
.
Assignee: general → peterlubczynski
QA Contact: general → bmartin
See also bug 204017. Sorry for the spam.
I experienced same hang problem sometimes until 20030729-trunk/Win-Me but hang
seems to disappear on 2003073110-trunk/Win-Me.

I found that already added file types are not diaplyed on "Preference/Helper
Applications" by 20030729-trunk/Win-Me build but they are displayed properly by
2003073110-trunk/Win-Me build.
These file types were saved in mimeTypes.rdf in profile directry when unknown
mime_type/file_type was detected in the past.
I guess that main reason of hang/crash is this inproper mimeTypes.rdf handling
by Mozilla.  
What will happen with 20030731 build or newer?

I found another funny phenomennon with 2003073110-trunk/Win-Me.
After opening PDF file at Mozilla's tab, task list of MS Windows(CTRL+DEL) says
Acrord32 process is active.
When I started stand alone Acrobat Reader 6 while Mozilla opens a PDF file and
closed Acrobat Reader without opening any PDF file, Acrobat Reader asked
"Browser opens a PDF file. Exit now or not?".
If I answer "Exit", task of Acrord32 disappered and PDF data displayed in
Mozilla's tab was destroyed.
After stopping Acrord32 process, I could close tab normaly.
(Note : This may cause crash of Mozilla. I experienced crash sometimes when I
killed Acrord32 from task list.)

In addition to this problem, Acrobat Reader 6 has another problem;
> Bug 147309 Ignoring Adobe Acrobat reader settings for "Display PDF in Browser"

I think they are Acrobat Reader 6's bugs but I guess that inproper Mozilla's
mimeTypes.rdf processing caused hang/crash of Mozilla in conjunction with these
Acrobat Readers's bugs.
What will happen when you start/stop Acrobat Reader 6 before closing tab?
If you open a PDF in a new tab, then start Acrobat 6.0 outside the browser,
invariably, you can close the tab in Firebird without fear of a crash.  The
dismissal of the PDF file is handled correctly.
I believe this bug is completely same as bug 212067.

MichaelC, will a workaround I described in 7-th comment in bug 212067 work at
your environment?
( http://bugzilla.mozilla.org/show_bug.cgi?id=212067#c7 )
I can confirm this. Glad I found this bug, I was about to file a new one for this.

I'm on Win98SE. For me though, the browser doesn't hang forever, but for 2 to 4
seconds, when closing the tab or window with a pdf desplayed. This is really
annoying, since users expects a tab/window to be dismissed immediately, and not
to wait a few seconds before the window/tab actually closes. So for me on
Win98SE, this is more of a performance issue. I'll leave the hang keyword for
now, but I might add perf keyword later is others confirms what I get.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I also experience this with Firebird 0.7 and Acrobat Reader 6.0 running on
Windows XP. I have the Tabbrowser Extensions, All-In-One Gestures, and Things
They Left Out installed. It's really annoying because I open a lot of PDF files
in the browser.
I can confirm that the workaround suggested by MichaelC in Comment #6 works for
me as well with Firebird 0.7 running on Win2k.  As long as I have an Acrobat 6.0
session open before attempting to close either a tab or window with a PDF file
loaded it will close immediately as expected.  If I don't, then Firebird will
hang for approx 30 seconds - gobbling up all available CPU cycles - and then the
tab or window will close.
I can confirm similar behavior also. When It hangs on me when trying to close or
by clicking the back button it will do so indefinitely and I have to close
mozilla or firebird (both exhibit the same behavior) forcefully via task
manager. Then I need to close the hung AcroRd32.exe process before I can use
acrobat again (standalone or as a browser plug-in).

System Info:

Windows XP Pro SP1

Mozilla 1.5 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007)

Firebird 0.7 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7)

Acrobat Reader 6.0.0.2003051900
verified on win2k with the 2003202504 build.
When you try to close a window or tab with a pdf in it, the cpu usage goes to
100% and mozilla just sits there. After minutes it enevtually comes back, but
its faster to kill the process and restart. That is if you can get to the task
manager.
I just downloaded and installed the 6.0.1 patch/update for Acrobat 6.0 and it
has fixed this problem with Firebird!  Firebird no longer hangs when trying to
close a PDF window or tab regardless of whether there is another session of
Acrobat open or not.
I also installed the 6.0.1 update for Acrobat Reader and it
really has fixed this problem with Mozilla. I suggest that this bug is closed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208
The patch worked for me also.
I've had the same problem with Firebird 0.7 (and 0.7+) and Acrobat reader 6.0
... (windows XP)
When i opened a pdf in a tab browser, and then close the browser, there was a
message box saying that the pdf will be close (ok, cancel), and then, after the
close, firebird was not reponding, with 97-99% cpu --> only one solution: kill
the app.

I've just downloading acrobat reader ENU 6.0.1.3 and now, there is no problem...
For Firebird 0.7 Win32, Acrobat Reader 6.0.1, I have success also.  Be warned,
though, that Reader will stay resident in memory until Firebird closes.  For me,
it's only ~20MB out of an even gig, but that's in the background with all but 2
of the .api drivers removed.  Although this new version doesn't hang the
browser, I suggest that this bug remain open because:
1) Not everyone will know to install a new version of Acrobat.
2) The browser still can't cleanly drop a plug-in with a large shut-down overhead.
3) There is no guarantee that Adobe or someone else won't make another bloated
plug-in that actually -listens- to shut-down requests from the browser.  This
"fix" from Adobe seems like a dirty hack to me, actually.
Perhaps another thread should be spawned for plug-in shut-down control, as sad
as that would be.  Hanging the UI just isn't excusable.
The browser no longer hangs, but I can confirm that the Reader does stay in
memory until everything is closed.  In Mozilla 1.7a {Build ID: 2004010508}, you
must kill the mozilla.exe process, including the icon in the systray, to get the
Reader to unload.
To unload Acrobat completely - assuming you're no longer viewing a PDF document
- just open Acrobat (it should open almost instantaneously) and then close it. 
There's no need to shut down Mozilla or Firebird.  I think that the current
behavior, i.e. the browser plug-in staying loaded, is preferred because it makes
opening subsequent PDF documents much quicker.  I also suggest that this bug
should be closed.
As mentioned in previous comments, testing indicates that upgrading to Acrobat
Reader 6.0.1 fixes this bug.  

As such am resolving as Works For Me.  Please reopen this bug if problems persist. 
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
Same thing happened to me. What happens is when you go to close Firebird Acrobat 
Reader pops up a dialog saying that another program is trying to close Acrobat Reader 
and do you want to close it. It took me a while to find this dialog because when you click on 
Firebird it blocks the dialog and you can't get to it (Alt-Tab, etc....). You just have to get this 
dialog to come up then click Yes and I think there's a checkbox to never show this again. IF 
you can get the dialog to the front, this workaround fixes the problem. 
*** Bug 252048 has been marked as a duplicate of this bug. ***
*** Bug 294456 has been marked as a duplicate of this bug. ***
*** Bug 261011 has been marked as a duplicate of this bug. ***
*** Bug 266698 has been marked as a duplicate of this bug. ***
*** Bug 311191 has been marked as a duplicate of this bug. ***
*** Bug 327190 has been marked as a duplicate of this bug. ***
Summary: Unload of Acrobat 6.0 hangs browser → Unload of Acrobat 6.0(.0) hangs browser (note:resolved by 6.0.1)
*** Bug 307516 has been marked as a duplicate of this bug. ***
*** Bug 219987 has been marked as a duplicate of this bug. ***
*** Bug 255223 has been marked as a duplicate of this bug. ***
*** Bug 332103 has been marked as a duplicate of this bug. ***
*** Bug 348267 has been marked as a duplicate of this bug. ***
*** Bug 350198 has been marked as a duplicate of this bug. ***
*** Bug 332800 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.