Keyboard navigation of 'Add Bookmark' 'Create in:' incorrect

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: dasnyderx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Adding a page to the bookmarks (either through Ctrl+D or Bookmarks->Bookmark
This Page) causes the 'Add Bookmark' dialog to appear. Moving the focus to the
'Create in:' listbox and having the listbox expand, when I use the up- and
down-keys to navigate the options in the listbox, the order of the highlighted
items is incorrect.  For example, I have three items listed (from top-to-bottom)
in the 'Create in:' listbox:  Bookmarks, Perl pages (official), and Bookmarks
Toolbar Folder.  Moving the focus to the 'Create in:' listbox causes the listbox
to expand with the first item (Bookmarks) highlighted.  Pressing the down-arrow
to move the focus changes the focus (and highlighted item) to the third item in
the listbox, 'Bookmarks Toolbar Folder'.  The expected highlighted item _should_
be the second item, 'Perl pages (official)'.  Pressing the down-arrow again,
causes the highlighted item to be the second item ('Perl pages (official)'). 
Continued pressing of the down-arrow causes the first item (Bookmarks) to be
highlighted, and the cycle repeats.  If a fourth bookmark folder (e.g.
Bookmarks, ECC sites, Perl pages, Bookmarks Toolbar Folder top-to-bottom 'Create
in:' listbox listing) is added, the keyboard navigation cycle is (assuming 'ECC
sites' is visible in the 'Create in:' entry area and using either the up- or
down-arrow), 'ECC sites' and 'Bookmarks Toolbar Folder' exclusively.  Adding a
fifth bookmark folder (e.g. bug sites, Bookmarks, ECC sites, Perl pages,
Bookmarks Toolbar Folder top-to-bottom 'Create in:' listbox listing) causes the
focus order to be, 'bug sites', 'ECC sites', 'Bookmarks Toolbar Folder',
'Bookmarks', and 'Perl pages (official)'.

Reproducible: Always
Steps to Reproduce:
1.Open the 'Add Bookmark' dialog.
2.Change focus to the 'Create in:' listbox and cause it to show all the bookmark
folders.
3.Change the highlighted bookmark folder using the up- or down-arrow.

Actual Results:  
From a top-to-bottom listing of the 'Create in:' drop-down of 'folder 1',
'folder 2', 'folder 3', 'folder 4', and 'folder 5', the order of highlighting
and traversal is folders 1, 3, 5, 2, and 4.  On a 'Create in:' drop-down of
'folder 1', 'folder 2', 'folder 3', and 'folder 4', the order of highlighting
and traversal is _only_ folders 1 and 3.

Expected Results:  
From a top-to-bottom listing of the 'Create in:' drop-down of 'folder 1',
'folder 2', 'folder 3', 'folder 4', and 'folder 5', the order of highlighting
and traversal is folders 1, 2, 3, 4, and 5.  On a 'Create in:' drop-down of
'folder 1', 'folder 2', 'folder 3', and 'folder 4', the order of highlighting
and traversal is _only_ folders 1, 2, 3, and 4.

Comment 1

14 years ago
I was just about to report this myself.  Seeing the exact same thing with

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Assignee: vladimir → nobody
Status: ASSIGNED → NEW
Mmm, 0.9. Please reopen (with longwinded and exact keystroke steps, please) if you still see this in 2.0, or a trunk build once Places is disabled, but this appears to me to be long since fixed, somewhere somehow.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.