If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Compact Folders deleted ~250 messages from Inbox

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Mike Brzozowski, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: version 0.7.1 (20040626)

In a POP inbox with one unread message (and none slated for deletion), I clicked
File, Compact Folders. When the folder re-opened, the most recent ~250 messages
from the Inbox had disappeared (about 19 days' worth). They were not in the
Trash or in any of the files in my profile folder. 

Reproducible: Didn't try
Steps to Reproduce:
Unable to reproduce it because I'm afraid to compact my folders again. The step
I took at the time was to compact the folders.
Actual Results:  
About 250 messages disappeared from the Inbox.

Expected Results:  
All messages I didn't delete should still be there.

Comment 1

13 years ago
version 0.8 (20040902)
No mail disappears here when compacting.
Could you back up your profile (copy the profile folder to another directory)
and test it? If mail gets deleted just remove the profile and move/copy your backup.
(Reporter)

Comment 2

13 years ago
Sorry, I'm unable to replicate it. Compact Folders works fine for me now.

Comment 3

13 years ago
I'm resolving this bug WFM per reporter's comment 2.  However, see bug 209883 
comment 2 which states that this symptom does exist but can be fixed by deleting 
the index file for the folder.
Mike Brzozowski, if the problem recurs, try that workaround; if it fails to 
bring the messages back, please reopen this bug and provide whatever new detail 
you can.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.