"checked" status of radio buttons does not respond to page refresh (potential duplicate of 249972)

RESOLVED DUPLICATE of bug 46845

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 46845
13 years ago
4 years ago

People

(Reporter: Dave Weaver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

This may be a duplicate of bug 249972; I'm not quite clear from reading that bug
report, as I am not using a database. When I am editing a page in a text editor
that contains radio buttons, I need to close and re-open Firefox in order to get
a "checked" attribute to change properly; the "refresh" button does not do it.

Reproducible: Always
Steps to Reproduce:
- Save the following as an HTML file:
<input name = "test" type = "radio" value = "1">

- Open this in Firefox.

- In a text editor, add a "checked" attribute to this radio button and save the
file.

- click "refresh" in Firefox.
Actual Results:  
the radio button does not become checked.

Expected Results:  
the radio button should become checked.

If, when I am editing this HTML, I change the "name" attribute in addition to
the "checked" status, the change does show up when I click "refresh."

My apologies if this is a duplicate; I found the other bug a little unclear.
Hopefully my "steps to reproduce" will still be of service.

Comment 1

13 years ago
Also happens in Mac OS; all Flash elements 'disappear' when I scroll a page or
resize the window. Right-clicking and choosing "Zoom in" then "Show all" from
the Flash context menu forces a redraw.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913
Firefox/0.10 StumbleUpon/1.998

Comment 2

13 years ago
(In reply to comment #1)
Sorry, disregard that comment, it belongs on a different bug. Didn't realize
Bugzilla moved me to another page.

Comment 3

13 years ago
I am seeing the same type of behaviour when refreshing.  I am running Firefox
1.0 on Windows.

Comment 4

13 years ago
(In reply to comment #3)

Same here. Initial page load  shows the radio as checked when the "checked"
attribute is present on the element. After a form submission and a tap of the
back button, and a refresh, the rafio will not return to its default state of
checked.

WinXP Pro, FireFox 1.0/20040711 r.v:1/75

Comment 5

13 years ago
I programmed a page that shuffles the Radio Buttons and one of them is
checked(the one with the right ID).
If you enter the page the first time everything is allright. Lets say the 3rd
entry is checked then. If you press reload the 3rd entry(the one with the
checked atrtribute) is now on place 5 but the Radiobutton is still checked on
place 3.

Comment 6

12 years ago
If you have 2 or more items on a radiobutton and the last one is checked, for
example, if you hit refresh, it jumps to the one before the last and goes on,
until it disappear... It seems the index that controls the current checked item
is not working well.
isn't this a duplicate of bug 46845 or bug 249972?
Assignee: bugs → nobody
Whiteboard: dupeme

Comment 8

11 years ago
If you add a RESET button to the form, then after the refresh (which does not show expected changes) clicking the RESET button will show the correct 'checks'.

As a workaround you can add 'document.forms[0].reset()' in script tags at the end of the doc, and this does correctly show the 'CHECKED' values even though the original reload did not.
(In reply to comment #7)
> isn't this a duplicate of bug 46845

Yes.

*** This bug has been marked as a duplicate of 46845 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.