Crash when doing multiple advanced address book searches

RESOLVED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Stefan Borggraefe, Assigned: Stefan Borggraefe)

Tracking

(Blocks: 1 bug, {crash})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

6.32 KB, patch
neil@parkwaycc.co.uk
: review+
Scott MacGregor
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

14 years ago
MailNews suffers from the same crash as TB did. See bug 251605.
(Assignee)

Comment 1

14 years ago
Created attachment 154097 [details] [diff] [review]
Port of the Thunderbird Fix
(Assignee)

Updated

14 years ago
Attachment #154097 - Flags: review?(neil.parkwaycc.co.uk)

Comment 2

14 years ago
Comment on attachment 154097 [details] [diff] [review]
Port of the Thunderbird Fix

I think that the sort column and direction should be retained across searches.
Checking against the message search, I notice that bienvenu broke it over a
year ago - the indicators no longer appear :-(
Attachment #154097 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Assignee)

Comment 3

14 years ago
Created attachment 156134 [details] [diff] [review]
Hopefully better patch

Ok, this patch retains the sort order and fixes the crash. I tested the Address
Book window itself, the Advanced Address Book Search dialog and the Select
Addresses dialog with different profiles (including newly created profiles with
no address book entries).
(Assignee)

Updated

14 years ago
Attachment #154097 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #156134 - Flags: review?(neil.parkwaycc.co.uk)

Updated

14 years ago
Attachment #156134 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Updated

14 years ago
Attachment #156134 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #156134 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 4

14 years ago
Comment on attachment 156134 [details] [diff] [review]
Hopefully better patch

Asking for approval. This fixes a crasher in the advanced address book search
and makes sure the sort order of the columns is retained after a search
operation. Should be pretty safe.
Attachment #156134 - Flags: approval1.8a3?

Comment 5

14 years ago
Comment on attachment 156134 [details] [diff] [review]
Hopefully better patch

a=asa for checkin to 1.8a3
Attachment #156134 - Flags: approval1.8a3? → approval1.8a3+
(Assignee)

Comment 6

14 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 7

14 years ago
*** Bug 255973 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Blocks: 239474
Depends on: 251605
Blocks: 437378
Blocks: 260289
You need to log in before you can comment on or make changes to this bug.