Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 253255 - Saving modified draft to server drafts folder doesn't set IMAP \draft flag
: Saving modified draft to server drafts folder doesn't set IMAP \draft flag
Status: RESOLVED DUPLICATE of bug 156347
: polish
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: unspecified
: x86 Windows 2000
: -- normal with 4 votes (vote)
: ---
Assigned To: Scott MacGregor
Depends on:
  Show dependency treegraph
Reported: 2004-07-27 05:18 PDT by Michael Wild
Modified: 2005-10-13 13:21 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description Michael Wild 2004-07-27 05:18:21 PDT
User-Agent:       Opera/7.53 (Windows NT 5.0; U)  [en]
Build Identifier: version 0.7a (20040614)

Using IMAP, set Drafts to a server folder. When a draft message is edited and 
saved back to the folder, as expected the original is deleted but not expunged, 
and the modified one is saved. However, the \draft flag for the modified message 
is not set on the server. The modified message can still be edited OK in 
Thunderbird; but if the server has a webmail interface, it can't be edited via 
that, because the \draft flag wasn't set.

Reproducible: Always
Steps to Reproduce:
1. At, use TB to open an existing draft, modify, and save.
2. Open the expunged message using the FM web interface. It opens with the edit-
message view.
3. Open the modified message using the FM web interface. It opens with the read-
message view form.

Actual Results:  
Modified draft message can be edited in TB, but not on the server.

Expected Results:  
At step 3 the modified message should have opened with the edit-message view. It 
does not, because TB saved the modified draft without setting the \draft flag. 

This is apparently identical to unresolved Mozilla mail/news bug 156347 http:// - further information is in a thread 
Comment 1 Michael Wild 2004-07-27 23:14:57 PDT
Typo in report. 

In "steps to reproduce", at step 2:
> 2. Open the expunged message using the FM web interface. It opens with the
> edit-message view.
"expunged" should be "deleted".

So step 2 should read:
2. Open the deleted message using the FM web interface. It opens with the edit-
message view.
Comment 2 Bob Peers 2004-09-16 11:12:16 PDT
I'm using the milestone 0.8 and can confirm this problem. The same is true for
newly created drafts saved to the IMAP server.
Reproducible: Always
Steps to Reproduce:
1. Write new message and save into IMAP server draft folder.
2. Open saved message in Tb brings the expected edit message window.
3. Open the saved message via webmail and it opens in a view message window not
available for editing since the \Draft flag is not on the server.

I can confirm this since I have telnetted into my IMAP account (Fastmail) and
fetched the message flags, it is very clear that Tb does not send the flag when
using the append command. I also logged the IMAP protocol for Tb while saving a
draft, the output can be seen here:

Interestingly the same code is used when copying a sent message to an IMAP
server, it is appended with the \Seen flag which is correctly set to stop it
showing as a new message.

Finally looking at the source code, this is the function to append to the server:

I'm no C++ expert but it seems from here:

 if (flags)
       command.Append(" (");
       SetupMessageFlagsString(flagString, flags,
that for drafts the variable flags ==0 causing no flagstring to be sent with the
append command.
Comment 3 David Rolfe 2004-12-13 23:52:38 PST
This is also related to the (2 years) old, old bug:

Comment 4 Gervase Markham [:gerv] 2005-09-27 01:49:57 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Comment 5 Bob Peers 2005-09-27 08:11:24 PDT
Just tested this on Thunderbird 1.06 and the same occurs as previously noted.
Comment 6 David Rolfe 2005-09-27 15:13:42 PDT
The blocking bug #156347 seems to have the wrong 'component' set. I wanted to add a comment to say 
still "broke for me". 
Comment 7 Wayne Mery (:wsmwk, NI for questions) 2005-10-13 13:21:31 PDT
same issue

*** This bug has been marked as a duplicate of 156347 ***

Note You need to log in before you can comment on or make changes to this bug.