Highlight doesn't work with pretty-printed XML files

RESOLVED DUPLICATE of bug 599804

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 599804
14 years ago
5 years ago

People

(Reporter: Luca M., Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

90 bytes, application/xhtml+xml
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040727 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040727 Firefox/0.9.1+

Highlight doesn't work with XML files (from Find toolbar)

Reproducible: Always
Steps to Reproduce:
1. Open an XML file
2. type any word that is present in that file in Find Toolbar (CTRL+F)
3. Click on Highlight



Expected Results:  
the words should be highlighted

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Highlight doesn't work with XML files → Highlight doesn't work with pretty-printed XML files
QA Contact: ian
(Reporter)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Reopening - this was never fixed.
Confirming with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2)
Gecko/20050603 Firefox/1.0+
Status: RESOLVED → REOPENED
OS: Windows 2000 → All
Hardware: PC → All
Resolution: FIXED → ---

Updated

13 years ago
Status: REOPENED → ASSIGNED
*** Bug 296362 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: firefox → nobody
Status: ASSIGNED → NEW
QA Contact: ian → fast.find
This is works for me with current Firefox trunk build.
Version: unspecified → 2.0 Branch
*** Bug 348378 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
This regressed on trunk.
Now, find doesn't work unless you focus the document by hand, first.
"Highlight all" didn't work at all, and still doesn't work at all.
Version: 1.8 Branch → Trunk

Comment 6

8 years ago
Still does not work in rv:1.9.2 Gecko/20100115 Firefox/3.6

Comment 7

6 years ago
Created attachment 657903 [details]
test case

Firefox 15.0 is still affected. I encountered this bug at first at http://www.opengl.org/sdk/docs/man/xhtml/glCopyPixels.xml
The attached test-case exposes the bug:

1. Open test.xml
2. Open the Find toolbar (Ctrl + F)
3. Type "Test" (there will be some results)
4. Press Highlight all (Alt + A)

5. "Phrase not found" (expected two highlighted words)

Updated

6 years ago
Attachment #657903 - Attachment mime type: text/plain → application/xhtml+xml

Comment 8

6 years ago
There is a patch from KUROSAWA, Takeshi in bug 599804.

Comment 9

5 years ago
Fixed by bug 599804, which is basically the same bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599804
You need to log in before you can comment on or make changes to this bug.