Highlight all doesn't work with non HTML documents (e.g. CSS styled XML files)

RESOLVED FIXED in mozilla24

Status

()

Toolkit
Find Toolbar
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Takeshi Kurosawa, Assigned: Takeshi Kurosawa)

Tracking

Trunk
mozilla24
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Highlight all doesn't work with non HTML documents even if the term hits when using normal search.
(Assignee)

Comment 1

8 years ago
Created attachment 478723 [details] [diff] [review]
Patch

Use doc.documentElement when doc.body doesn't exist.

This also works with the testcase of bug 495141.

Comment 2

5 years ago
Hi.  You needed to request a review.

There is an older bug on this: bug 253261.

Updated

5 years ago
Attachment #478723 - Flags: review?

Comment 3

5 years ago
Comment on attachment 478723 [details] [diff] [review]
Patch

> Hi.  You needed to request a review.
...it's also better to request it from a specific person. Tagging adw, since the last review in this file was his.
Attachment #478723 - Flags: review? → review?(adw)

Comment 4

5 years ago
Comment on attachment 478723 [details] [diff] [review]
Patch

Review of attachment 478723 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch, Takeshi, and thanks for the review redirection, Nickolay.
Attachment #478723 - Flags: review?(adw) → review+

Updated

5 years ago
Status: NEW → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/2c7c1df9dc9b
Assignee: nobody → taken.spc
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2c7c1df9dc9b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24

Updated

5 years ago
Duplicate of this bug: 253261
Duplicate of this bug: 771876
You need to log in before you can comment on or make changes to this bug.