All users were logged out of Bugzilla on October 13th, 2018

IE Debug message pops up when pressing "Submit" in Edit Attachment

RESOLVED DUPLICATE of bug 313069

Status

()

--
minor
RESOLVED DUPLICATE of bug 313069
14 years ago
13 years ago

People

(Reporter: pjdemarco, Assigned: myk)

Tracking

2.16.4
x86
Windows 2000

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: 2.16.4

I got the wonderful IE "Do you want to debug?" question when I changed the mime 
type to: "application/msword" and pressed "Submit"

Reproducible: Didn't try
Steps to Reproduce:
1. Create an attachment that is a Word.Doc file but attach it incorrectly as a 
image/jpeg
2. Click the "Edit" next to the attachment
3 [review]. Change mime type to: application/msword
4. Press submit

Actual Results:  
Gave the "Do you want to debug?" pop up dialog.
Then worked fine.

Expected Results:  
Work fine without pop up dialog.

This may only happen on a developer's PC with Visual Interdev.  I think this 
makes things a little more picky about small errors.
(Reporter)

Updated

14 years ago
Version: unspecified → 2.16.4

Updated

13 years ago
QA Contact: mattyt-bugzilla → default-qa
I can reproduce this on the current 2.16 branch tip, 2.18 branch tip but NOT on 2.20 branch tip or trunk.

Only happens on IE, Firefox seems to be unaffected. Anykind of attachment change triggers this. Seems to happen in the normalizeComments(); JS function that is called from the onsubmit handler of the form. After canceling popup, the change seems to proceed normally.

This bug seems to be caused by the following lines in generated JS code inside the normalizeComments() function:
    var small = document.getElementById('smallCommentFrame');
    var big = document.getElementById('editFrame');
    if ( small.style.display == 'none' ) {...}
    if ( big.style.display == 'none' ) {...}
These only work on a DOM-compliant browser. On other browsers small and big variables will be null/undefined.

This bug seems to have been fixed in bug 313069.

*** This bug has been marked as a duplicate of 313069 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.