Closed Bug 253891 Opened 15 years ago Closed 14 years ago

each search-plugin should be available via context-menu for selected words, like it currently only works for google

Categories

(Firefox :: General, enhancement)

x86
All
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 248173

People

(Reporter: norbert.notz, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8a3) Gecko/20040731 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8a3) Gecko/20040731 Firefox/0.9.1+

I think I have a nice idea: :-)

If you select a word in a web-page and right-click, in the conext-menu is an
item "Search Web for "[SELECTED TEXT]"".

I guess it does the same like when entering the word in the search-bar while
google is selected. But it's possible to have also other search-plugins installed.
I suggest that for all search-plugins, there should be such an context-menu item
available. So the user could easily select a word and search for it at ebay or
amazon or whatever he has installed as search-plugin.

Reproducible: 
Steps to Reproduce:
[moved to component general, because of the conext-menu improvement. feel free
to re-assign the component.]
Component: Find Toolbar / FastFind → General
I think that the names of the context-menu items should be directly derived from
the corresponding name in the search bar:

"Search [SEARCHENIGNE-NAME] for "[SELECTED TEXT]""

for example the goole item sould then be named: "Search Google for "[SELECTED
TEXT]""


if the user has additionally an Amazon search-plugin installed and has selected
the word "Linux", the following items should be available:
- "Search Google for "Linux""
- "Search Amazon for "Linux""
(In reply to comment #2)

typing error: "goole item" -> "google item"
OS: Windows 95 → All
Dupe of bug 232272. Whether it will be a context menu or something in the
Options, isn't decided yet.

*** This bug has been marked as a duplicate of 232272 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
sorry, wrong bug
sorry, wrong bug
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
The Context Search extension will help you, but that won't be included in
Firefox, see bug 248173.

*** This bug has been marked as a duplicate of 248173 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.