Closed Bug 248173 Opened 16 years ago Closed 16 years ago

The Context Search extension should be in Firefox

Categories

(Firefox :: Search, enhancement)

x86
All
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jaap, Assigned: p_ch)

References

()

Details

(Whiteboard: [parity-ie])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

Normally I do not use the search web functionality in the context menu because
it searches on google and I almost never have selected text I want to lookup in
google, but more in other engines such as imdb or dictionary.com or the wikipedia

The following extension adds all your search engine as a submenu to the search
web item

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
sorry I made a mistake. Don't look at my comment in #1
Sorry forgot to mention the site for context search

http://forums.mozillazine.org/viewtopic.php?t=75294
I don't think we want to do this.  The implementation of bug 203959 is, I
believe, sufficient for the majority of users.  Its an interesting extension,
there's also something ben wrote as an extension to use bookmark keywords in a
submenu (note that he didn't implement anything like this in Firefox core).

This would make a compact, elegent context menu into something much different. 
Most people leave the search engine on their favourite/most commonly used search
engine, so the other implementation makes more sense in that context.  We're
already working on making context menus less bloated, this would be a step in
the opposite direction.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → WONTFIX
(In reply to comment #4)
> I don't think we want to do this.  The implementation of bug 203959 is, I
> believe, sufficient for the majority of users.  Its an interesting extension,
> there's also something ben wrote as an extension to use bookmark keywords in a
> submenu (note that he didn't implement anything like this in Firefox core).
> 
> This would make a compact, elegent context menu into something much different. 
> Most people leave the search engine on their favourite/most commonly used search
> engine, so the other implementation makes more sense in that context.  We're
> already working on making context menus less bloated, this would be a step in
> the opposite direction.

Of course it's your call, but in the context menu I (I guess like most people)
mostly use a dictionary search engine and in the search bar a web search engine.
I think that's the reason why they should be independent.
(In reply to comment #5)
> (In reply to comment #4)
> > I don't think we want to do this.  The implementation of bug 203959 is, I
> > believe, sufficient for the majority of users.  Its an interesting extension,
> > there's also something ben wrote as an extension to use bookmark keywords in a
> > submenu (note that he didn't implement anything like this in Firefox core).
> > 
> > This would make a compact, elegent context menu into something much different. 
> > Most people leave the search engine on their favourite/most commonly used search
> > engine, so the other implementation makes more sense in that context.  We're
> > already working on making context menus less bloated, this would be a step in
> > the opposite direction.
> 
> Of course it's your call, but in the context menu I (I guess like most people)
> mostly use a dictionary search engine and in the search bar a web search engine.
> I think that's the reason why they should be independent.


Disagree. If I see something on a page and a right click can look it up one of
several ways, THAT is bringing ease of use to my "end user experience". A
dictionary, google, or whatever is doing the searching can be the plugin part of
this.
(In reply to comment #6)
> 
> Disagree. If I see something on a page and a right click can look it up one of
> several ways, THAT is bringing ease of use to my "end user experience". A
> dictionary, google, or whatever is doing the searching can be the plugin part of
> this.
> 
I think you misunderstand me. context search gives you the opportunity to look
it up in several ways.

The thing is the search bar I usually have set on google. If I want to do a
context search I usually want to lookup a word in a dictionary. So everytime I
want to do a context search I first have go to the searchbar to change the
search engine to for example dictionary.com and then do the context search. For
this I have to do quite some more clicking then if you use context search.
Furthermore as I already said before, I think it's not logical that if you
selected a search engine in the search bar that then the search web context item
will all of sudden use that search engine. There is not the slightest hint that
they are connected.  (Maybe the icon can be copied can be copied to the context
menu)
Should this one be reopened and then later resolve as fixed based on new search
stuff in the browser?
*** Bug 307250 has been marked as a duplicate of this bug. ***
*** Bug 253891 has been marked as a duplicate of this bug. ***
Blocks: 232272
*** Bug 330401 has been marked as a duplicate of this bug. ***
*** Bug 344190 has been marked as a duplicate of this bug. ***
*** Bug 348570 has been marked as a duplicate of this bug. ***
*** Bug 360606 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 404037
To me this is a serious usability issue and will make for a great enhancement to all users. I only reported this after countless times that I had to make round trips to the search bar to change my default search engines every time I wanted to search the selected text using Google, Logos or Merriam-Webster.

Compare this with Windows File Explorer Open command. Most of the time you want to open a file using its default application for the file extension. But quite often you want to open the file using a different application. Therefore, Windows enhances Windows File Explorer usability by giving you Open With command in the same context menu.

Implementing Search With submenu does not have to clutter the selected text context menu. It can neatly appear before "More Search Types->" which I haven't really found a use for yet. Example, context menu:

...
----------------------
Search With ->
More Search Types ->
Send To ->
...

There may be other clever ways of implementing this but the goal would be to give user the option of choosing what search engine to use to search the selecte text. Like it is already mentioned, there may be different types of information on the same webpage: URL, foreign words, etc and it is not correct to assume that the user will want to use the same search engine to search for all selected text

Need to add the "Polish" and "UE" key words.
Duplicate of this bug: 404727
Duplicate of this bug: 417353
Both IE8b2 and Opera now includes this feature, can we re-consider this?
i agree.
i use context search exactly for the cases i wish to use a non-common search engine.
Duplicate of this bug: 583674
But I think it's a shame not to implement the feature. It comes with IE right out of the box so at least it should be implemented in the near future.
Duplicate of this bug: 583674
If the search engines are selectable from the context menu, it would fit the usability rule of proximity: You should not be forced to jump from the point of focus (a selected word or phrase) to another point (search engine list) and back to perform an action.

The search engines would be much more usable if you can choose the search engine directly at the query word.
Duplicate of this bug: 606299
Wontfixed 6 years ago, time to reconsider? This is a very useful feature in IE and Opera.
perhaps we can even use split menus as in the new firefox button. this will allow both one-click functionality, and multi-search choice.
Whiteboard: [parity-ie]
Adding Alex Faaborg to CC
Isn't one of the competing browsers now doing this?
Created a Bug 770967 which might deal with this. IE has these accelerators , but we don't really have to reinvent anything , we already have keyword mechanism which can help us solve the problem. I hope developers consider this :)
Seeing a recent Mozilla Air has changed my mind about this.. We often refine after searching not the other way round. Inserting icons of other search engines in a search results page is a better idea.
Search tabs are for stuff you search by typing , but the context menu searching is about searching selected text on say google , wikipedia , youtube etc. Entirely different thing .
Duplicate of this bug: 814798
Could this one please be reconsidered?
You need to log in before you can comment on or make changes to this bug.