Dragging shortcut to link onto FireFox doesn't open page

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Peter Buck, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When a desktop link to an HTML page is dragged onto FireFox, the following error
message is displayed:

C:\DOCUME~\PZG4PX\LOCALS~1\TEMP\9am87ycf.lnk could not be saved, because an unknown
error occurred.

Sorry about that.  Try saving to a different location.

Clicking on the shortcut does properly open the page (in a new browser window).
 And dragging the page from Explorer into FF also opens it.

Reproducible: Always
Steps to Reproduce:
1. create html page
2. create desktop shortcut to page
3. drag shortcut onto FF

Actual Results:  
C:\DOCUME~\PZG4PX\LOCALS~1\TEMP\9am87ycf.lnk could not be saved, because an unknown
error occurred.

Sorry about that.  Try saving to a different location.

Expected Results:  
displayed the page
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040801
Firefox/0.9.1+

WFM

Comment 2

14 years ago
Was going to duplicate to bug 246078, but 0.9.2 WFM also, so that's not the cause.

Reporter: try this.
1) Set Internet Explorer to the default browser.
2) Set Firefox to the default browser. (This will reset the registry keys).
3) Use the workaround from comment 139 in bug 246078. (So you don't see that
problem only).

I'm guessing you have a bad registry entry, but not the same one as caused by
bug 246078.

Setting WORKSFORME, reopen only if following the steps above doesn't fix the
problem for you, AND the latest nightly build also fails.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 3

14 years ago
*** Bug 253953 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
*** Bug 345154 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
I can still reproduce this issue with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060714 BonEcho/2.0b1 Firefox/1.5 ID:2006071403
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

12 years ago
The shortcut does not need to be an HTML document. I reproduced with a shortcut to an XML document and txt document.

Comment 7

12 years ago
Internet Hyperlinks appear to work fine.  However any hyperlink other than an Internet Hyperlink throws this error.  The error no longer says "Sorry about that.".

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
QA Contact: ali → file.handling
Assignee: bugs → nobody

Comment 8

11 years ago
This is now WORKSFORME (shortcuts behaving as symlinks) with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/2007052307 Minefield/3.0a5pre

Not fixed on the 1.8.1 branch though (Firefox 2.0.0.4 RC3).
Status: NEW → RESOLVED
Last Resolved: 14 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.