Spell check should not apply for internationalized message

RESOLVED DUPLICATE of bug 69687

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED DUPLICATE of bug 69687
14 years ago
13 years ago

People

(Reporter: Seiji Kaneko, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

Spell checking features in thunderbird works when message is not written in
English. It should check a MIME-character encoding field in header.

Reproducible: Always
Steps to Reproduce:
1. Spell check for a message (like Japanese or Korian)
2.
3.

Actual Results:  
Thunderbird tries to check spelling and generate odd results.

Expected Results:  
Skips spell checking.

It doesn't occur on 0.7. I think this bug is introduced 0.7.1.

Updated

14 years ago
Summary: Password check should not apply for internationalized message → Spell check should not apply for internationalized message

Comment 1

14 years ago
I don't think checking MIME-character encoding is a good idea to take decisions
on spelling. I personally use ISO-8859 encoding to write messages in english,
french and spanish . Ans MIME-encoding happens _after_ the message has been
composed, doesn't it ?

Perhaps this should be a ENH request for a default language preference of
message composition, with various languages fallbacks (like the languages
preference for the FireFox browser), with a button to choose alternate languages
on a per-message basis ?

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 69687 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.