If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cpu utilization constantly high, stays at near 100% when firefox is waiting for a response from a server.

RESOLVED DUPLICATE of bug 252513

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 252513
13 years ago
13 years ago

People

(Reporter: k s, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

As an example, my laptop has two fans: one is constantly one, the other comes 
on when it starts getting too hot.  I can do practically anything on my laptop 
except intensive graphics w/o the second fan coming on.  Until in installed 
FireFox... when I have firefox running my second fan is on most of the time.  
(I can also watch the temperature monitor on my system and see it shoot up as 
the CPU gets a workout.)

Of course the above is a symptom - the problem, which I identified by watching 
the task manager processes, is firefox CPU utilization shoots up to 80-100% 
when in active use (browsing).  

For example, on my machine (2.4ghz p4) going to news.google causes firefox cpu 
usage to go up to 92%.  If I visit the same page in MSIE cpu usage tops out at 
20% (and yes, the page appears just as fast).

If I hit a slow responding site with firefox cpu usage goes into the upper 90s 
and stays pinged there until a response comes back.  Doing the same in MSIE 
cpu usage is < 10%.

Reproducible: Always
Steps to Reproduce:
1. Open up firefox
2. Go to any website that has a slow response
3. Look at CPU utilization

Actual Results:  
CPU usage pinged at > 90%

Expected Results:  
Lower CPU usage, especially while waiting for a response from a server.

none - except that as a developer with 20 some applications open I can't use 
firefox because it "kills" my system's performance
(Reporter)

Updated

13 years ago
Summary: Cpu utilization constantly high when, stays at 100% when firefox is waiting for a response from a server. → Cpu utilization constantly high, stays at near 100% when firefox is waiting for a response from a server.
(Reporter)

Comment 1

13 years ago
I'm not sure why my "build identifier" is showing Firefox/0.8 --  my about box 
states "Firefox/the browser, reloaded/version 0.9.1"

Comment 2

13 years ago
sounds like a duplicate of Bug 252513

*** This bug has been marked as a duplicate of 252513 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.