Last Comment Bug 255014 - upload progress bar for large form submission
: upload progress bar for large form submission
Status: RESOLVED DUPLICATE of bug 249338
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- enhancement with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 349717 362405 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-10 02:59 PDT by matthew arnison
Modified: 2008-06-11 00:19 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description matthew arnison 2004-08-10 02:59:48 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040730 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040730 Firefox/0.9.1

When uploading large files through a form, firefox does not give any indication
of progress. Yet it knows the size of the file(s) it is sending. For large
files, the user is left hanging with no idea how long the form submission will
take. There are many web sites which accept large files through web page forms.

Reproducible: Didn't try
Steps to Reproduce:
1. Go to web form which accepts large files.
2. Browse... to a local large file.
3. Submit the form.

Actual Results:  
The browser says it is sending the form, and the pointer and toolbar icons rotate. 


Expected Results:  
There should be an indication of percentage, relative or absolute progress. For
example, the progress bar in the lower right corner of the status bar should
update to show the relative progress in sending the file(s).

This was fixed in the browser component, see bug 24197.
Comment 1 Kramer 2005-05-03 15:38:04 PDT
The reporter's OS may have been Linux, but, obviously, this is neded for Windows
as well.  Some of my web apps accept file uploads that total in excess of 300MB;
and this feature would be very nice for impatient users (myself included)
Comment 2 Jesse Ruderman 2006-12-02 03:12:02 PST
*** Bug 362405 has been marked as a duplicate of this bug. ***
Comment 3 Jesse Ruderman 2006-12-02 03:12:42 PST
Bug 362405 suggested putting the progress indication in the file upload control, but I think the status bar makes more sense.
Comment 4 Declan Naughton 2007-03-17 03:10:14 PDT
(In reply to comment #3)
> Bug 362405 suggested putting the progress indication in the file upload
> control, but I think the status bar makes more sense.
> 

For pages with more than one control, having the progress indication in the control would be useful.
Comment 5 Thomas Bertels 2007-08-07 02:35:40 PDT
*** Bug 349717 has been marked as a duplicate of this bug. ***
Comment 6 Thomas Bertels 2007-11-09 15:53:52 PST

*** This bug has been marked as a duplicate of bug 249338 ***

Note You need to log in before you can comment on or make changes to this bug.