Closed Bug 255035 Opened 18 years ago Closed 15 years ago

Chinese text is rendered with mixed serif and sans-serif fonts

Categories

(Camino Graveyard :: Page Layout, defect, P2)

PowerPC
macOS

Tracking

(Not tracked)

RESOLVED FIXED
Camino1.6

People

(Reporter: stephen, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040809 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040809 Camino/0.8+

When using serif font for Traditional Chinese text, some text is rendered with
mixed serif and sans-serif fonts.

Reproducible: Always
Steps to Reproduce:
1. Set the Serif font for Traditional Chinese to Apple LiSung and Sans-Serif
font to Apple LiGothic.
2. Open the attached html sample.

Actual Results:  
The 3rd and 6th characters are rendered in Sans-serif font while every other
ones are in Serif.

Expected Results:  
All characters rendered in Serif font.

Tested in OS X 10.3.4.
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.8a3) Gecko/20040809 Camino/0.8+
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.8a3) Gecko/20040809 Camino/0.8+

Reporter could you test with Mozilla the suite or with FireFox so we can
determine if the problem is Camino speciifc or not.
Tried with FireFox 0.9.3 and it works properly. Setting fonts in preferences to
use Serif and the text is rendered completely in specified Serif font.
This bug is related to bug 175651.

for the present, open prefs.js and add this line:
user_pref("font.name.serif.zh-TW", "Apple LiSung Light");
user_pref("font.name.sans-serif.zh-TW", "Apple LiGothic Medium");
Confirmed using 2004101408 (v0.8+) NB on 10.3.5.

Firefox 20041018 (0.9.1+) doesn't show this behaviour.

Note that Camino is setting Lisung Light and Medium for Serif and Sans but both
are not installed on default so we are doing something wrong on default here.

Leaving severity high as this is a big issue for Chinese users.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think setting the proper defaults for the languages is only half of the
solution. Whenever user changes the font settings, the problem comes back for
the font names written to the prefs are not what the code (don't know which part
of it) expects to use.
The Carbon/Cocoa mismatch on what to call the fonts (waverider's bug 175651
comment 14) is in play for both setting the defaults and for recording what the
user changes the fonts to.

(Jasper, those fonts are installed...Camino just names them differently when
writing to prefs--Camino only recognizes/writes the font family; Gecko wants
family + style/weight--see waverider's comment.)

It's possible that bug 246527 is also in play if the user sets the fonts Apple's
newer Chinese fonts (as Asaf Romano explained in layman's terms, Gecko doesn't
know how to handle some of the newer fonts), but if Firefox remembers the choice
of newer font and displays the text in the correct font, it's definitely the
conflict between Camino's Cocoa UI and Carbon Gecko.
Depends on: 301740
Priority: -- → P2
Target Milestone: --- → Camino1.0
Ping? For 1.0?
I *think*, like bug 278255, this will be fixed when Simon fixes bug 175651 to make the Advanced fonts sheet use Carbon names.  That's why it's a depends of bug 175651.
-> 1.1
Target Milestone: Camino1.0 → Camino1.1
Assignee: mikepinkerton → nobody
QA Contact: page.layout
-> 1.2, like bug 175651 
Target Milestone: Camino1.1 → Camino1.2
This should be fixed by bug 175651.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.