The default bug view has changed. See this FAQ.

When saving a draft, progress dialog box title first says "Sending messages" and then sometimes changes to "Saving messages -"

RESOLVED FIXED in Thunderbird 17.0

Status

MailNews Core
Composition
--
minor
RESOLVED FIXED
13 years ago
5 years ago

People

(Reporter: David Grant, Assigned: aceman)

Tracking

({ux-userfeedback})

Trunk
Thunderbird 17.0
ux-userfeedback
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

12.03 KB, patch
aceman
: review+
Ian Neal
: review+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Webemu/0.9.2 (All your Firefox/0.9.2 are belong to Firesomething)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Webemu/0.9.2 (All your Firefox/0.9.2 are belong to Firesomething)

Save a draft, then a window appears briefly and the title of that window says
"Sending Messages..." then it changes to "Saving Messages" or something like
that.  I think it helps if your draft is large, then the little dialog is open
long enough so that you can read it.

Reproducible: Always
Steps to Reproduce:
1. Save a draft, a large one
2. Notice the pop-up dialog window title says "Sending Messages..."
3. Get scared.

Actual Results:  
Notice the pop-up dialog window title says "Sending Messages..."

Expected Results:  
It shouldn't say "Sending Messages..."

Comment 1

13 years ago
My eyes aren't fast enough to be 100% sure but I think I can see this under 
0.7+ (20040810).

Comment 2

13 years ago
I see this too. It'easier to see if you have a slow IMAP server.

Confirming, setting severity to minor.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
Confirmed on TB 0.8, W2000pro with local folders.

There is a related bug that says it was fixed in 2001, but apparently it either
came back or didn't make it into TB: #86398.

Comment 4

12 years ago
Perhaps related problem - on my nightly build (a couple of weeks old) very often
upon attempt to save draft it says CAN NOT SAVE MESSAGE IN SENT ITEMS FOLDER.
Seems something is messed up here.

Comment 5

11 years ago
It is still there in Thunderbird version 1.0.7. It can be really annoying, because the user gets the impression that she/he hit the wrong button.

Comment 6

10 years ago
It's not just the status bar message - there is also dialog boxes that pop up to say that the encoding has problems (and asks you what to Send the message as whereas its really only saving it) or to say there was an error sending (as opposed to saving)
This still happens in 2.0.0.0
OS: Windows 2000 → All
Hardware: PC → All
Version: unspecified → 2.0
QA Contact: general

Updated

9 years ago
Assignee: mscott → nobody
Duplicate of this bug: 594042
Ben using version 6 wrote:
"However large the email body or attachments, the dialog box only appears during a fraction of a second and I cannot read the title. "

Comment 9

5 years ago
Well Ben using version 6 must have a fast computer, network connection, and IMAP server and never have any issues in the connection.  I still see this as a daily annoyance triggering a wave of concern every time I see "failed to send message," "sending message," "Thunderbird is in the process of sending a message," etc. when I'm saving a draft that's not ready to be sent.  This seems to be a copy/paste error in the code, either with a string, string name, or function call.
This bug, the fact that it has been around since 2004 and still is not fixed, and my experience trying to address it remain as a unit the single greatest reason why I don't recommend Thunderbird.  That kind of error would be OK for research-grade software where most users are developers, but not in something ready for prime time.  A spelling or grammar error, OK; but "sending" instead of "saving draft" is qualitatively a different action.  Getting it wrong (in either direction) can have significant consequences for the sender, and the negative consequences (when the sender knows that they exist) are first felt when you first see the software indicate the wrong one.

Comment 10

5 years ago
if it's not obvious, the reason the messages are wrong is because the code that saves drafts and the code that copies to the sent folder is shared code, not a copy paste error.

Comment 11

5 years ago
Duplicate of Bug 257735?
(Assignee)

Comment 12

5 years ago
OK, I see it now too. The title flashes as "Sending messages" and then changes to "Saving messages -" (even with the dash). On slow machines (disk I/O, low RAM) it could be visible for a second.

The problem seems to be this:
The dialog is initialized here http://mxr.mozilla.org/comm-central/source/mailnews/compose/content/sendProgress.xul with the title set to be "Sending Messages". Then only once it loads it determines if it is actually sending or saving and sets the proper title (the code here http://mxr.mozilla.org/comm-central/source/mailnews/compose/content/sendProgress.js#135).

Maybe the setting operation is sometimes too slow.
I am not sure I can move it any sooner in the code flow. But at least we could either:
1. set the initial dialog title to something neutral, e.g. "preparing operation"
2. or let the initial title be blank until the proper string is determined.
Bwinton?
Assignee: nobody → acelists
Component: General → Composition
Keywords: uiwanted, ux-userfeedback
Product: Thunderbird → MailNews Core
Version: 2.0 → Trunk
(Assignee)

Updated

5 years ago
Duplicate of this bug: 647681
(Assignee)

Comment 14

5 years ago
While there maybe the strings could be fixed up a bit better.
http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/messengercompose/sendProgress.properties

The title is in plural, but the final status message (messageSent) is in singular. Can there really be multiple messages in progress while this dialog is up?

Then, the title concatenates the Save/Send string with the message subject. This could be made properly localizable, like "Sending Messages - %S".
Summary: When saving draft, dialog box says "sending..." → When saving a draft, progress dialog box title first says "Sending messages" and then sometimes changes to "Saving messages -"
(Assignee)

Comment 15

5 years ago
When I have simple email with a big attachment, the title reflashes to the correct string immediately.
When I have a large HTML email, the string is bad for a long time (and the dialog is empty) and only reflashes at the end.

It may be that in some cases the onLoad() method of the dialog does not get to execute soon enough. Maybe other code (msg parser) runs sooner and starves the dialog.
(Assignee)

Comment 16

5 years ago
Created attachment 643531 [details] [diff] [review]
patch

So this is my proposal. Is it better?
Attachment #643531 - Flags: ui-review?(bwinton)
Attachment #643531 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 17

5 years ago
Oh, I should probably change the stringIDs in the .properties file too...
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED

Comment 18

5 years ago
Comment on attachment 643531 [details] [diff] [review]
patch

As you said, need to change the entity names. I couldn't see the initial title no matter what size draft I tried to save though.
r=me with entity names changed
Attachment #643531 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 643531 [details] [diff] [review]
patch

I like it.  I think it would be nice to have a message with an empty subject say "Saving Message" instead of "Saving Message - ", but you get the ui-r=me even if you don't make that change.

Thanks,
Blake.
Attachment #643531 - Flags: ui-review?(bwinton) → ui-review+
(Assignee)

Comment 20

5 years ago
Created attachment 645051 [details] [diff] [review]
patch v2

Ok, added.
Attachment #643531 - Attachment is obsolete: true
Attachment #645051 - Flags: review?(mkmelin+mozilla)

Comment 21

5 years ago
Comment on attachment 645051 [details] [diff] [review]
patch v2

Review of attachment 645051 [details] [diff] [review]:
-----------------------------------------------------------------

Thx for the patch! r=mkmelin

::: mailnews/compose/content/sendProgress.js
@@ +124,5 @@
>          subject = progressParams.subject;
>        }
>      }
>  
> +    let prefix = itsASaveOperation ? "titlePrefixSaveMsg" : "titlePrefixSendMsg";

I know this is copied, but i would not form the localization keys on the fly, it makes them hard to find and otherwise error prone. Just assign the full key name where you need it.
Attachment #645051 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 22

5 years ago
Created attachment 646885 [details] [diff] [review]
patch v3

Thanks!
Attachment #645051 - Attachment is obsolete: true
Attachment #646885 - Flags: review+
(Assignee)

Updated

5 years ago
Keywords: uiwanted → checkin-needed

Comment 23

5 years ago
Should probably have some suite people look at it too as it's suite/ too
Keywords: checkin-needed
(Assignee)

Comment 24

5 years ago
I've got r+ from IanN in comment 18. Do you mean there are some new important changes that he didn't see?

Comment 25

5 years ago
Comment on attachment 646885 [details] [diff] [review]
patch v3

To make everyone happy r=me
Attachment #646885 - Flags: review+

Updated

5 years ago
Keywords: checkin-needed

Comment 26

5 years ago
Ah, no, just didn't notice it in the comments
https://hg.mozilla.org/comm-central/rev/1d9804d82741
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 17.0
(Assignee)

Updated

5 years ago
Duplicate of this bug: 774172
You need to log in before you can comment on or make changes to this bug.